Automic Workload Automation

Expand all | Collapse all

Unix Jobs getting on Hold

  • 1.  Unix Jobs getting on Hold

    Posted 06-08-2016 01:12 AM

    Hi,

    I have a workflow, where its restarting Unix servers.
    After the server goes down, the job goes in Hold state, due to which the workflow is halted in between.

    The server is rebooting fine, but the job getting on Hold
    I tried putting maximum runtime for 5 min, so that after that it moves onto next job in workflow , but still it goes into Hold state.
    I have to manually right click on the job and unhold the job for the workflow to continue.

    I have attached the job report log and the server logs for your reference.
    Thanks and Regards,
    Avinash



  • 2.  Unix Jobs getting on Hold

    Posted 06-08-2016 09:42 AM
    I don't see any reports / logs.

    It sounds like what's happening is the agent goes down, so the job goes into a "waiting for host" status.  Setting a max runtime here won't help because that is calculated or started based on when the job STARTS.  Which it hasn't - cause it's still waiting to start.

    If you don't want this job to run if the agent is unavailable, then you could use some UC4 scripting and do a SYS_HOST_ALIVE I guess in the Pre Process and if it isn't up do a STOP NOMSG or something like that.  Then the jobflow would continue on.

    There may be a more elegant way to do this in PreConditions now in 11.2, but I'm not as familiar with those yet.


  • 3.  Unix Jobs getting on Hold

    Posted 06-09-2016 12:02 AM

    Hi,

    The agent is going down and its coming up and connection is properly established.

    But after that the job goes in Hold state(yellow), which causes the workflow to get paused at that job only and it does moved on to the next job in the workflow.

    Thanks and Regards,

    Avinash