Layer7 API Management

Expand all | Collapse all

Restoration of Gateway

Jump to Best Answer
  • 1.  Restoration of Gateway

    Posted 06-05-2017 12:00 PM

    Hi,

     

    For testing purposed, I have backed up a gateway by following the method described inside (https://docops.ca.com/ca-api-gateway/9-2/en/administer-the-gateway/back-up-gateways). As a result, a zip file has been created.

     

    When I try to restore a newly created gateway by using that zip file as described here (https://docops.ca.com/ca-api-gateway/9-2/en/administer-the-gateway/restore-gateways), I get the message that the restoration has been successful and that a restart is required. I use the command as mentioned in docops (/opt/SecureSpan/Gateway/config/backup/ssgrestore.sh [options]). However, when the gateway is rebooted, the network connectivity between the host machine and the gateway always fails. Do you have some idea what may be the problem?

     

    Regards,

    Panagiotis



  • 2.  Re: Restoration of Gateway
    Best Answer

    Posted 06-05-2017 03:39 PM

    Hi Panagiotis,

    Have you tried reconfiguring the network settings 1) Configure system settings -> 1) Configure networking and system time settings?

    I've encountered some issues when restoring to different environments and have to reconfigure the network.



  • 3.  Re: Restoration of Gateway

    Posted 06-06-2017 09:31 AM

    Hello Mohindra,

     

    Thanks for the hint. Indeed, I had taken a whole image of the gateway including the network settings. Consequently, when I made the backup, all settings were being changed.

     

    After selecting only the specific parameters that I needed (I excluded the OS files), there was no issue.

     

    Regards,

    Panagiotis