Service Virtualization

Expand all | Collapse all

Getting Error on deploying MAR file

Jump to Best Answer
  • 1.  Getting Error on deploying MAR file

    Posted 06-13-2017 02:20 AM

    Hello Team,

     

    I am getting below error when deploying .MAR file. I checked it is having correct format. Also I tried in different VSEs and not able to to deploy. Please find error message below.

     

     

    Thanks..

     

    Shivam Garg



  • 2.  Re: Getting Error on deploying MAR file

    Posted 06-13-2017 06:08 AM

    Hi Shivam.garg

     

    How did you create a mar file, did you use make mar utility or downloaded it from devtest portal ?

     

    Try the following ,

     

    1. check if the VSM or VSI file is corrupted, if its not corrupted then,

    2. Delete the Virtual service mar file from VSE Deploy folder and redeploy. if you still were not able to deploy, then

    3. create a mari file and deploy the mari file.

     

    If everything is good and you still face the issue then restart of devtest vse service might help.

     

    To know more on the issue check the vse.log file

     

    Thanks,

    Venkatesh



  • 3.  Re: Getting Error on deploying MAR file

    Posted 06-16-2017 02:09 PM

    VenkateshSatturi could be on to something with the suggestion: Delete the Virtual service mar file from VSE Deploy

    I have seen this issue occur on Linux/Unix platforms when the system has run out of space on the volume where LISA_HOME is mounted.

     

    You might also consider removing large, unused files such as the various xxxx.log_1 thru xxxx.log_5 entries.

     

    Also, what is the size of the virtual service image inside the MAR? I believe DevTest extracts the contents of the MAR prior to deployment.

     

    And, are the 'different VSEs' running on the same machine or on different machines?



  • 4.  Re: Getting Error on deploying MAR file

    Posted 06-16-2017 01:48 PM

    Shivam,

     

    Did Venkatesh's recommendations help you out with this issue?



  • 5.  Re: Getting Error on deploying MAR file
    Best Answer

    Posted 06-18-2017 11:15 PM

    Hi Shivam,

     

       Looks like there is something wrong with the MAR file which you are using to deploy. Please create mar file using below steps and try deploying it again.

          Deploy Your Virtual Service - DevTest Solutions - 10.1 - CA Technologies Documentation 

     

    Thanks

    Srikanth