Automic Workload Automation

Expand all | Collapse all

Unable to use wildcard in EVNT Object

  • 1.  Unable to use wildcard in EVNT Object

    Posted 09-30-2016 01:22 PM
    Hi all,

    I have made a workflow, within this workflow there is a JOBS windows, the JOBS windows is used for reading some information from a VARA STATIC object that contains 4 columns.

    c88z4tv05xse.jpg



    h1ecpcpwccis.jpg

    I am using the following code in the preprocess tab of windows job :
    I parse the VARA object and I trigger some other jobs on the files found  depending on the ACTION (column 2)
    BZP : The file should be backed up, Zipped and encrypted uing PGP
    BZ : The file should be backed up, Zipped
    etc ...

    n5czd5d74paf.jpg

    Check file is done using an EVNT file, the file name is a variable and it works, but when I am using wildcards, it does not detect files

    fkvx4m2ouh3p.jpg

    if the file in &FILE# is FILE it works, if it is FI* nothing is detected.

    Someone can help please ?

    Regards,
    Kalid


  • 2.  Unable to use wildcard in EVNT Object

    Posted 10-04-2016 11:30 PM

    Hi Khalid,

    what does the report of the EVNT show?



  • 3.  Unable to use wildcard in EVNT Object

    Posted 10-05-2016 02:26 AM

    And what’s about the Agent Log File, does it show any error message?
    Another questions could be:

    • Does it work in case FI* is used instead of the variable?
    • Does it work with UNC path instead of drive letter?


  • 4.  Unable to use wildcard in EVNT Object

    Posted 10-05-2016 04:25 PM
    Kalid Okabbad has reported that the cause of the original issues has been corrected:

    Thanks both for you answers, I have checked my workflow and there was a typo in the "!Process" tab, I have corrected it

    At this point, Kalid have another new issues and so new discussion has been created for the new questions/issues; whichcan be found here.