Layer7 API Management

Expand all | Collapse all

API Gateway 9.2 / OTK 3.6 woes

Jump to Best Answer
  • 1.  API Gateway 9.2 / OTK 3.6 woes

    Posted 06-22-2017 07:53 AM

    Hi,

    In order to test migration from Gateway 9.1 / OTK 3.5 /MAG 3.2 to 9.2 / 3.6 / 3.3, we've built a "reference" environment, in order to test this.

    It appears that no OTK endpoint are working:

     

    /mag/manager does works. Other APIs, including RESTman are working.

     

    Steps used to migrate:

    - upgrade 9.1 to 9.2

    - remove previous solution kits: MAG and OTK

    - install new solutions kits

     

    Detailed error as seen in audit events:

    20170622 13:48:00.138WARNING2

    service is resolved but the corresponding policy is invalid for service GOID e001cfd0c1c1ffaa18e187b5e72fea4e (oauth/manager). Exception caught!

     

    Policy does show up some warning, but as it also does on 9.1/3.5

     



  • 2.  Re: API Gateway 9.2 / OTK 3.6 woes
    Best Answer

    Posted 06-26-2017 08:14 PM

    Hello PhBrand ,

    Did you try restarting gateway? I saw another case with the same error resolved by just restart gateway, maybe due to some assertion was not loaded to memory.

     

    Regards,

    Mark



  • 3.  Re: API Gateway 9.2 / OTK 3.6 woes

    Posted 06-28-2017 09:44 AM

    Hi,

    Guess what, you're right

    Forgot to restart ssg service. It does now works.



  • 4.  Re: API Gateway 9.2 / OTK 3.6 woes

    Posted 06-29-2017 04:27 AM

    Hi PhBrand,

     

    FYI, if you're upgrading your APIm environments to last versions, you may be interested to know :

     

    - MAG 4.0 has been released

    - OTK 4.0 has been released

    - GMU 1.4 has been released

     

    Have a nice day



  • 5.  Re: API Gateway 9.2 / OTK 3.6 woes

    Posted 06-29-2017 05:10 AM

    Hi Nicolas, long time no see

    We're actually building a migration plan to reach ultimatly this goal.

    OTK/MAG 4.0 requiers Gateway 9.2, while we're still on 9.1.

    Plan is first to upgrade to 9.2, then OTK/MAG 3.6/3.3 then OTK/MAG 4.0.



  • 6.  Re: API Gateway 9.2 / OTK 3.6 woes

    Posted 06-30-2017 04:03 AM

    If you're already aware of it, perfect PhBrand