Automic Workload Automation

Expand all | Collapse all

Changing HOST attribute on a generated and activated JOB possible?

  • 1.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-14-2014 06:56 AM


    Is it possible to change the HOST (or HOSTGROUP) attribute on a already generated and activated JOB-Objects and afterwards rerun the JOB? Or is the only way to handle that in canceling and starting it all the way new with the desired HOST (or HOSTGROUP) attribute?



  • 2.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-14-2014 10:22 AM

    Most all of our objects are marked as Generate at runtime on the Attributes tab.  We use a PUT_ATT to actually set the Host name as the object is executed.  We also sometimes use this to change the host on a restart after checking its mode with the SYS_ACT_RESTART function.

    We do not use HOSTGROUPS, and as I don't see it as an attribute (for V8) I would guess this is not a modifiable attribute.



  • 3.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 04:15 AM

     

    Actually we do not set the HOST via PUT_ATT. Its selected through the drop down box in the GUI. And the question is if it's possible to change the entry of that box on a generated and activated job objects afterwards and then restart the job with a rerun.


  • 4.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 04:31 AM

    this is not supported: as soon as the JOBS object is generated you can only change the JCL but not the other attributes. This applies to HOSTs as well as HOSTGROUPS (evaluating the HOSTG is only an additional step).

    You could use "generate at runtime" as mentioned by Mark. This allows you to change/edit the object before the AE generates the object. An alternative is to enable the "attribute dialog" if this will happen often.


    Finally: what is the reason to change the host before the job runs on an agent?



  • 5.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 04:45 AM

    The reason was a ENDED_NOT_OK run of the Job due to a faulty agent. So we tried to rerun the same job with a different agent. This was not possible because we couldn't change the agent afterwards.



  • 6.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 05:13 AM

    I guess the most convenient way to change the host (as well as other parameters) is to RESTART the failed object and select "activate attribute dialog"dzagtb4td1se.jpghttps://us.v-cdn.net/5019921/uploads/editor/l0/dzagtb4td1se.jpg" width="1095">



  • 7.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 06:26 AM

     

    Thank you! We tried that and unfortunately got the following error:

    U0020521 Laufzeitfehler in Objekt 'ATTRDIA.WINDOWS' Zeile '00074': Es wurde versucht den Host zu wechseln, nachdem eine Host-Variable ausgewertet wurde.



  • 8.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 07:32 AM
      |   view attached
    I tried it again on my system and recorded a video (attached). Have you performed the same steps? I use v10 SP2 - which version do you use?

    Attachment(s)



  • 9.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 10:29 AM

     

    Thanks again! We did it exactly that way using AE v9 SP4.


  • 10.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-15-2014 01:13 PM

    I just completed the test on v9 (AE: 9.00A408-791, DB: 9.00A408-791): I got the same result as with v10. Restart with "attribute dialog" has worked fine: frst executopn on WIN64, restart with changing the host to WIN32


    aevwwkyzecrt.jpghttps://us.v-cdn.net/5019921/uploads/editor/va/aevwwkyzecrt.jpg" width="1420">



  • 11.  Changing HOST attribute on a generated and activated JOB possible?

    Posted 05-19-2014 03:52 AM

    Strange. We do need to test the scenario here again i assume. Thanks for you very helpful support!