IDMS

Tech Tip: CA IDMS CV Startup Slow

  • 1.  Tech Tip: CA IDMS CV Startup Slow

    Broadcom Employee
    Posted Mar 27, 2018 09:22 AM

    Issue:

    Our CV is taking much longer than normal to startup.

     

    Cause:

    This can be caused by startup AUTOTASKs, particularly if they have the PREEMPT option set.

    Startup AUTOTASKs are submitted between the following two messages:

    11.56.42 JOB04436 +IDMS DC013006 V7 T0 ATTACHING STARTUP AUTOTASKS

    11.56.42 JOB04436 +IDMS DC013005 V7 T0 CENTRAL VERSION INITIALIZATION COMPLETE

    If a startup AUTOTASK has the PREEMPT option, then that task must complete before user tasks are allowed to run.

    This can have the effect of delaying startup.

     

    Resolution:

    Investigate any startup AUTOTASKs defined for the CV and ideally determine if any have the PREEMPT option.

    If it is acceptable for the application, change it to NOPREEMPT.

     

    Additional Information:

    AUTOTASK Statement Parameters - CA IDMS - 19.0 - CA Technologies Documentation