Layer7 API Management

Expand all | Collapse all

GMU -How to ignoreDependencies.

Jump to Best Answer
  • 1.  GMU -How to ignoreDependencies.

    Posted 04-06-2018 10:59 AM

    Hi,

     

    How to ignore Dependencies folder when doing GMU migrateOut and MigrateIN.

     

    I tried using "-includeOnlyServicePolicy" but I am getting an error. 

     

    Thanks,

    spallapu90



  • 2.  Re: GMU -How to ignoreDependencies.

    Posted 04-06-2018 11:34 AM

    Do you have the full migrateOut command you're using?  I don't have extensive experience with GMU but I have recently been engaged in similar issues.  I doubt it's the "-includeOnlyServicePolicy" switch that's causing your problem.  It's likely some other aspect of your migrateOut.  I do not believe that switch can be used for anything but migrateOut.  I've found the command output to be pretty good about telling you what the problem is.  Specifically what error are you getting?



  • 3.  Re: GMU -How to ignoreDependencies.

    Posted 04-06-2018 01:54 PM

    Hi StPaulPete,

     

    I wanted to ignore few dependencies which came out from migrateOut. i modified the mapping.xml file and that solved my issue.

    It seems "-includeOnlyServicePolicy" doesn't work with migrateOut, I was referring to CA Documentation migrateOut command - CA API Gateway - 9.2 - CA Technologies Documentation.

     

    Thanks for your help.

    -spallapu90



  • 4.  Re: GMU -How to ignoreDependencies.
    Best Answer

    Posted 04-06-2018 02:23 PM

    Just to clarify, --includeOnlyServicePolicy works with migrateOut, but if you use that you will get ONLY the service policy, no dependencies, so subsequent use of manageMappings will not have anything to work with.  If you use --includeOnlyDependencies, you will get ONLY the dependencies and no service, so migrateIn will not look like it does anything from a policy view, but it will actually migrate environment type things like private keys, etc.  If you use neither option you get both service policy export and dependencies by default.  Just went through that.