DX Application Performance Management

Expand all | Collapse all

Jenkins plugin no ATC data

Jump to Best Answer
  • 1.  Jenkins plugin no ATC data

    Posted 03-19-2018 06:50 PM

    Hi, has anyone successfully used or is using Jenkins plugin with CA APM?

     

    i've done the setup and i get successful build and stuff, and i can see apm data on jenkins but when i got to ATC i don't see any attributes updated automatically.

     

    I've checked data connection between jenkins and ca apm team center/webview and i didn't receive any data from jenkins end. Zero data on tcpdump, however i get data if i run tcpdump on MOM.

     

    Any ideas?



  • 2.  Re: Jenkins plugin no ATC data
    Best Answer

    Posted 03-19-2018 10:22 PM

    Hi Joao,

    The data should only be going to the MOM and getting stored in the SmartStor and the APM DB where it is read by WebView/Team Center.

     

    Are you able to see the Jenkins build metrics in WebView and just ATC has a problem?

    Is ATC showing other expected data from other agents/sources?

    You have all the pre-reqs installed e.g. XL Tool Kit?

    Jenkins Plugins 

    GitHub - jenkinsci/ca-apm-plugin 

     

    SrikantN for SME suggestions.

     

    P.S. It may be related to the public status of the MOM REST api which I think is needed to be enabled for the plugin to work.

    By default the public setting is disabled in later 10.x versions, so please check this property in MOM IntroscopeEnterpriseManager.properties file: introscope.public.restapi.enabled

     

    Thanks

     

    Lynn



  • 3.  Re: Jenkins plugin no ATC data

    Posted 03-19-2018 10:48 PM

    Hi Lynn,

     

    If i'm not mistaken, i haven't seen any data in Webview, i actually don't know what to look for once the plugin is configured. I know i'm not seeing anything on ATC, and couldn't find so far anything related in Webview also.

     

    When you ask if ATC is showing other expected data from other sources/agents.

    As far as i'm aware yes, we are using docker plugin also (for the same application) and the info is showing up there along with agents and browser agent info also, for ATC and web view i can see both.

     

    I got the xl toolkit (data.war) today and got a success connection message from the plugin side. Managed to get a regex to work also, since it was failing because it wasn't finding the metric on the apm side, did some tests and now it's working.

     

    On the plugin side there are two configuration fields for web view and its port, we filled it correctly.



  • 4.  Re: Jenkins plugin no ATC data

    Posted 03-20-2018 12:54 AM

    Hi Joao,

    Thanks for the reply.

    So introscope.public.restapi.enabled=true is set in your MOM IntroscopeEnterpriseManager.properties file? 

    Did you also set 8081 (not 8444) for the APM10 rest service port (that is now default for APM 10.5)

    APM REST API - CA Application Performance Management - 10.5 - CA Technologies Documentation 

     

    For the WebView side can you go from the Jenkins dashboard to CA APM Web View per the example on this page: Jenkins Plugins 

     

    Thanks

     

    Lynn



  • 5.  Re: Jenkins plugin no ATC data

    Posted 03-20-2018 06:20 AM

    Hi Lynn,

     

    Yes, introscope.public.restapi.enabled=true is set. Using 8081 for the web services port instead of 8444, tested it also with some urls for consulting data.

     

    Yes i can jump from jenkins dashboard directly into the metric in Webview if i click it, in this case i have Average Response Time.



  • 6.  Re: Jenkins plugin no ATC data

    Posted 03-20-2018 11:24 AM

    Hy Lynn and others who can help,

     

    I decided to check some other stuff about this problem, since nothing i do after the configuration is working.

     

    Tcpdump - decided to check this cause traffic usually shows it all.

     

    03 builds generated on jenkins, on every traffic file i see this:

     

    - HTTP Get Request - it comes all the data from APM - OK

     

    and after this  successful request i get another one with the following message every single time:

     

    - HTTP/1.1 400 Bad Request\r\n

     

    tcpdump command line: 

    tcpdump -s 0 -B 8096 -i eno16777984 host 10.67.123.180 -w tcpd2jenk.pcap

     

    Link to the pcap file:

    Microsoft OneDrive - Access files anywhere. Create docs with free Office Online. 

     

    =============================

    On enterprise manager log i receive also every few seconds a message related to token security:

    [INFO] [btpool0-300] [Manager.AppMap] Method http://10.166.227.14:8081/apm/appmap/graph/vertex/?_method=PATCH was called without existent token.

     

    The thing with this message is that /apm/appmap/graph/vertex  is an ATC REST API URL, not a mom rest url, but i don't know if this is related with my jenkins problem, since i'm receiving error messages related to docker plugin regarding failed addition of attributes to ATC.



  • 7.  Re: Jenkins plugin no ATC data

    Posted 03-20-2018 05:10 PM

    Hi Joao,

    Per the separate email thread you were copied on, SrikantN, who wrote the Jenkins plugin, has been talking with Angelo feran16 and they will be arranging a call to troubleshoot the problem.

    We can post the eventual resolution here.

     

    Regards,

     

    Lynn



  • 8.  Re: Jenkins plugin no ATC data

    Posted 04-05-2018 05:00 PM

    Hi Team, 

     

    Even Angelo Ferecini had made some tests, unfortunately this plugin didn't work on the customer environment.

    Could you please verify if it's possible to adjust it in order to run on the APM 10.5?

     

    Thanks and Regards,

     

    Monica



  • 9.  Re: Jenkins plugin no ATC data

    Posted 04-05-2018 08:26 PM

    Hi Monica,

    Please contact SrikantN for help with this.

    Thanks

    Lynn