Clarity PPM

Expand all | Collapse all

Upgrade issue - 14.3 patch 10 fails

Jump to Best Answer
  • 1.  Upgrade issue - 14.3 patch 10 fails

    Posted 04-09-2018 01:01 PM
      |   view attached

    Our current CA PPM version: 14.3.0.298 06 7

    We are in process of upgrading to 15.4, and one of the first steps is applying patch 10 on our 14.3 install.

    We are receiving the following error during the middle of running install.bat for patch 10:

     

     

    4/06/18 10:14 AM (ExecTask) Current database version is database_20160422_0545
    4/06/18 10:14 AM (ExecTask) DBDriver for database_20170112_1603
    4/06/18 10:14 AM (ExecTask) Start installation of DBDriver ...
    4/06/18 10:14 AM (ExecTask)
    4/06/18 10:14 AM (ExecTask) Note: Foreign Keys have been disabled
    4/06/18 10:14 AM (ExecTask)
    4/06/18 10:14 AM (ExecTask) DBDriver failed to install!
    4/06/18 10:14 AM (ExecTask)
    4/06/18 10:14 AM (ExecTask) Total time: 0H:0M:1S
    4/06/18 10:14 AM (ExecTask) Exception in thread "main" java.lang.Exception: DBDriver failed to install
    4/06/18 10:14 AM (ExecTask) at com.niku.dbtools.DriverApp.installSchemaDriver(DriverApp.java:911)
    4/06/18 10:14 AM (ExecTask) at com.niku.dbtools.Utilities.run(Utilities.java:1862)
    4/06/18 10:14 AM (ExecTask) at com.niku.dbtools.Utilities.main(Utilities.java:975)
    4/06/18 10:14 AM (ExecTask) Caused by: java.sql.SQLSyntaxErrorException: [CA Clarity][SQLServer JDBC Driver][SQLServer]Cannot find the object "Message" because it does not exist or you do not have permissions.

     


    Install log is attached.

    Note: The user NIKU is a member of DB_OWNER role. Other DB pre-requisites have also been taken care of.

     

     

    Has anyone seen this issue before?

    Any help in resolving this is greatly appreciated.

     

    Thanks!

    Attachment(s)

    zip
    install_log_apr6.zip   53K 1 version


  • 2.  Re: Upgrade issue - 14.3 patch 10 fails

    Posted 04-09-2018 01:32 PM

    Note: CA Support case 01006109 Appears to be open for this inquiry.



  • 3.  Re: Upgrade issue - 14.3 patch 10 fails
    Best Answer

    Posted 04-09-2018 03:12 PM

    The solution provided in Support case 01006109 seems to be correct. Would recommend review the permissions and apply exactly as our MSSQL/Oracle documentation show to see if this helps.

    https://docops.ca.com/ca-ppm/15-4/en/installing-and-upgrading/install-ca-ppm
    Set the CA PPM Database Required Oracle User Privileges
    Configure a CA PPM Database with Microsoft SQL Server