DX Application Performance Management

Expand all | Collapse all

Enabling REST API

Jump to Best Answer
  • 1.  Enabling REST API

    Posted 12-08-2017 11:18 AM

    Hi,

     

    I found the CA documentation and knowledge base article on how to enable the REST API, however had a few follow up questions.

     

    Documentation:https://docops.ca.com/ca-apm/10-3/en/integrating/api-reference-guide/apm-rest-api

    Knowledge Base Article: https://support.ca.com/us/knowledge-base-articles.TEC1748203.html

     

    When comparing the documentation to the knowledge base article, the documentation does not mention enabling the SSL in WebView.

     

    Do you need to enable SSL in WebView?

     

    If so, I noticed another knowledge base article regarding the WebView SSL (https://support.ca.com/us/knowledge-base-articles.tec1078428.html?intcmp=searchresultclick&resultnum=1) . This article is for releases 10.0 and 10.1, but wanted to confirm:

    1. Does this also apply to 10.3?

    2. If so, we are using a certificate authority for the REST API enablement on the MOM. Are there any additional configurations needed within WebView besides the properties file as mentioned in TEC1748203 to follow Resolution 1 in TEC1078428? Does this require another certificate or can the same certificate being used on the MOM for the REST API be used?

     

    Thank you,

    Sam



  • 2.  Re: Enabling REST API

    Posted 12-08-2017 11:49 AM

    The REST API resides on the EM, so no, you do not need to enable SSL for WebView.



  • 3.  Re: Enabling REST API

    Posted 12-08-2017 01:06 PM

    Thanks Haruhiko!

     

    We experienced an issue with port 8081 after enabling the REST API on the MOM and reverted the changes.

     

    Have you experienced / see this before? The error we received when trying to launch webstart:

     

    Network Error (tcp_error)

    A communication error occurred: "Connection refused"

    The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.



  • 4.  Re: Enabling REST API

    Posted 12-08-2017 02:39 PM

    Sounds like a port conflict.  Its connecting but not allowing access.  What do you see in the MOM log with debug enabled?



  • 5.  Re: Enabling REST API
    Best Answer

    Posted 12-08-2017 03:05 PM

    Unfortunately we reverted the changes we made to enable the REST API before putting the logs in debug mode. When we attempt enabling the REST API again we will make sure to put the logs in debug before the changes.

     

    Thanks!

    Sam