Clarity PPM1

Expand all | Collapse all

SSO with Clarity 15.3 - Report service 404 Not found

Mayank Joshi12-01-2017 12:46 AM

  • 1.  SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 12:26 AM

    Hello

     

    After having SSO enabled on Clarity 15.3 (fresh install) server, the Advance Reporting throws following error:

    404 Not Found.

    The requested URL /reportservice/flow.html was not found on this server.

     

    app-ca.log reports following error:

    SYS   2017-11-07 13:03:19,021 [localhost-startStop-1] niku.union (clarity:none:none:none) Clarity 15.3.0.200 ready.
    SYS   2017-11-07 13:03:30,224 [Event Interest Registration Thread] niku.union (clarity:admin:-1:none) Event registration has completed. The Event Manager started successfully.
    WARN  2017-11-07 13:04:06,443 [ajp-nio-8009-exec-7] utility.I18nUtilities (clarity:pjoshim:7424194__54D2C0BB-DCDA-4594-856D-7761EDEC3845:npt.overview) Unable to find gwtconstants/TimeZoneConstants for locale en finding default
    WARN  2017-11-07 13:04:06,537 [ajp-nio-8009-exec-7] utility.I18nUtilities (clarity:pjoshim:7424194__54D2C0BB-DCDA-4594-856D-7761EDEC3845:npt.overview) Unable to find gwtconstants/DateTimeConstants for locale en_US finding default
    WARN  2017-11-07 13:04:06,537 [ajp-nio-8009-exec-7] utility.I18nUtilities (clarity:pjoshim:7424194__54D2C0BB-DCDA-4594-856D-7761EDEC3845:npt.overview) Unable to find gwtconstants/DateTimeStringConstants for locale en finding default
    WARN  2017-11-07 13:04:07,771 [ajp-nio-8009-exec-8] caching.SecurityObjectCache (clarity:pjoshim:7424194__54D2C0BB-DCDA-4594-856D-7761EDEC3845:odata.GetNavigatorMenuBean)  Invalid security object key: BURDENING_MATRIXRECORDPAC



  • 2.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 12:32 AM

    Hi Mayank,

     

    Did you integrate Jaspersoft with PPM ? Reference can be found here https://docops.ca.com/ca-ppm/15-3/en/installing-and-upgrading/install-ca-ppm/install-and-configure-advanced-reporting-wi… 

     

    Regards

    Suman Pramanik 



  • 3.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 05:23 PM

    1. I can logon to Jaspersoft console as superuser.

    2. Clarity Job - "Create and Update Jaspersoft Users" ran successfully and I see the users in Jaspersoft GUI.

    3. 'Load Data Warehouse'  and 'Load Data warehouse Access rights' jobs ran successfully.

    4. Without SSO enabled, the Clarity user successfully ran reports (in New Tab only) from Advanced Reporting. Also could create new Views (in New Tab only).

    5. After enabling SSO, I can logon to Clarity without providing logon credentials. Once I click on "Advanced Reporting" I get the error as reporting in the beginning of this post.

     

    App-Ca.log reports:

    WARN  2017-11-08 09:11:48,197 [ajp-nio-8009-exec-7] caching.SecurityObjectCache (clarity:pjoshim:7426196__463D17E2-D88C-4D90-8054-7FA9A6E635B2:nmc.users)  Invalid security object key: BURDENING_MATRIX_ACCESSPAGEPAC



  • 4.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 05:35 PM

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

    <html><head>

    <title>404 Not Found</title>

    </head><body>

    <h1>Not Found</h1>

    <p>The requested URL /reportservice/flow.html was not found on this server.</p>

    </body></html>

     

     

    Suman,

    Please note that without SSO, the integration worked fine and reports were successfully run ** only when opened in a new tab**  .

     



  • 5.  Re: SSO with Clarity 15.3 - Report service 404 Not found



  • 6.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 01:09 AM

    NJ, 
    This thread is not relevant here. We dont know if there is any integration or not. Thats why I asked if Jaspersoft was integrated.

     

    Regards

    Suman Pramanik 



  • 7.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 05:26 PM

    Hello NJ,
    I did review this post earlier.

    Could you please provide more details on the server/folder/file name where this workaround is to be applied on the Proxy and reverse-proxy settings?

    Thank you.

    MJ



  • 8.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 06:25 PM

    Hi Mayank,

     

    Please confirm if had a chance to go through this article on Docops when Integrating CA PPM with CA Single Sign On.

     

    https://docops.ca.com/ca-ppm/15-3/en/add-ins-and-integrations/integrate-ca-ppm-with-ca-single-sign-on-sso 

     

    Configure the Application Bind Address, Port, and Proxy:

    1. In CA PPM System Administration (CSA), navigate to your server Properties.
    2. Click on the Application link.
    3. Configure the Apache Tomcat application server. 
    4. In the app instance settings, select the Use Single Sign-on option.
    5. If using mod_proxy (simple HTTP reverse proxy), configure the HTTP Port for the app instance to a non-privileged port. The 8080 port is used as an example. Configure the Bind Address field for the app instance (not the Tomcat Connector Bind Address) to the loopback address (127.0.0.1) if the Apache HTTP server is on the same host.
    6. If setting a proxy from Microsoft IIS or Apache HTTP Server with the Apache Tomcat Connector, the Apache Tomcat Connector requires configuration of the Tomcat Connector Port and Tomcat Connector Bind Address for the CA PPM app instance. The Apache Tomcat Connector uses the ajp13 protocol. Configure the connection to the Tomcat Connector Port and not the HTTP Port.

      1. Set the Tomcat Connector Port to a non-privileged port such as 30001.

      2. Set the Tomcat Connector Bind Address to the loopback address (127.0.0.1) if the Microsoft IIS or Apache HTTP server is on the same host.

    7. Click Save.

     

    Regards,

    Jeet Patel



  • 9.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-07-2017 08:02 PM

    Hello Jeet,

    Upto #4, it is all good.

    We have SSO configured fine hence able to logon to Clarity PPM without requiring to enter the logon username and password.

    The issue occurs only when trying to access report server via the "Advanced Reporting" link.

    #5 and #6 in the above post is not applicable in my case.

    Thank you.

    MJ



  • 10.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-08-2017 02:22 AM

    HI Mayank,

     

    We need to know more and its better to troubleshoot via support case. On a high level we need to see at what point URL is getting blocked. The SSO is at PPM and once you are in PPM it uses the session and user context to navigate to Advance Reporting. You can use browser tools to trace and see. 

     

    There is no special configuration needs but looks more at network layer.

     

    Regards

    Suman Pramanik 



  • 11.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-13-2017 05:32 PM

    Case #884078 raised.



  • 12.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 11-30-2017 11:58 PM

    The problem with Reportservice still continue.

    Turned on New User Experience and exactly same error I get, i.e.

     

    Not Found

    The requested URL /pm was not found on this server.



  • 13.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 12-01-2017 12:04 AM

    It looks like the way URL has been protected is causing issue, have you looked at the documentation 

     

    https://docops.ca.com/ca-ppm/15-3/en/add-ins-and-integrations/integrate-ca-ppm-with-ca-single-sign-on-sso 

     



  • 14.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 12-01-2017 12:44 AM

    I have referred to the above link earlier and made the pm to be unprotected.

    Unfortunately the problem continues.



  • 15.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 12-01-2017 12:46 AM

    Please find attached settings on SSO server.



  • 16.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 12-01-2017 01:26 AM

    Did you engage any of our SSO team. There is no configuration in PPM which needs to be done.

     

    Regards

    Suman Pramanik 



  • 17.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 12-03-2017 05:34 PM

    CA Case# 00891855 raised with SSO.

    Thank you.



  • 18.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 12-04-2017 11:49 PM

    Jaspersoft reports are working now:

    In httpd.conf file of the site-minder agent, I added the following entry:

    JkMount /reportservice/* clarity

    The reportservice URL becomes: http://pvjasd02.crimtracagency.corporate/niku/nu#action:nmc.advancedReporting

     

    We still need to work on the New User Experience:

    Repeated exact change for NUX as follows:

    Added following line in httpd.conf:

    JkMount /pm/* clarity

    The Web URL becomes: http://pvjasd02.crimtracagency.corporate/pm

    The error is: 404 - Not Found The requested URL /pm was not found on this server.

     

    What is the difference between New User Experience and ReportService, in terms of SSO configuration?



  • 19.  Re: SSO with Clarity 15.3 - Report service 404 Not found

    Posted 12-04-2017 11:52 PM

    Based on the work around suggested at

    https://support.ca.com/us/knowledge-base-articles.tec1407596.html 

    when I change the httpd.config for the site-minder agent, the Apache 2.2 service do not start up.

    ProxyPass / http://ClarityPPM.domain.com:80##/

    ProxyPassReverse /  http://ClarityPPM.domain.com:80##/

    or

    Add additional directives to handle the reportservice URI.

    ProxyPass /reportservice/ http://ClarityPPM.domain.com:80##//reportservice /

    ProxyPassReverse /reportservice / http://ClarityPPM.domain.com:80##//reportservice /

     

    Any suggestion, highly appreciated/

    Thank you.