Layer7 Access Management

Expand all | Collapse all

sm_user changed to smuser 

Jump to Best Answer
  • 1.  sm_user changed to smuser 

    Posted 12-05-2017 10:44 PM

    Hello there,

     

    We started seeing  the SM default headers name changed as below...

     

    sm_user changed to smuser and
    sm_serversessionid changed to smserversessionid

     

    Can anyone help me how to avoid this?

     

    Thanks



  • 2.  Re: sm_user changed to smuser 
    Best Answer

    Posted 12-05-2017 10:57 PM

    To enable legacy variables and have the Web Agent use underscores in the HTTP header names, set value of the ACO Parameter: LegacyVariables=yes.

     

    LegacyVariables

    Specifies if the Web Agent uses underscores in HTTP header names. With some web servers (such as the Sun Java System), using the underscore character in the HTTP headers causes problems with some applications.

    When this parameter is set to no, the HTTP headers will not have underscores, as shown in the following example:

    SMHeaderName

    When this parameter is set to yes, the HTTP headers will use underscores, as shown in the following example:

    SM_HeaderName

    Default: (traditional agents) Yes

    Default: (framework agents) No



  • 3.  Re: sm_user changed to smuser 

    Posted 12-06-2017 11:57 AM

    Thank you Makesh. it worked as per your suggestion.