Layer7 Access Management

Expand all | Collapse all

Issues with Cognos/siteminder integration

Jump to Best Answer
  • 1.  Issues with Cognos/siteminder integration

    Posted 11-22-2017 09:42 AM

    We have a 12.51 Policy server and a couple 10.2.1 Cognos servers using a 4.x enabled agent to connect the two. After weekly restarts this past sunday we were no long able to recieve the smsession token data into our cognos system. No changes were made to either side during the weekend but we had a failure none the less come money.

     

    The error we recieve from the cognos side is:

    We have verified the shared secret on the 4.x agent connection several times as well as verified that the namespaces within cognos have been able to connect to the user directories specified.

     

    Upon our last test with the namespace for siteminder we ran into this issue:

    Tested the CIS-DE namespace within cognos

    Errors:

    CAM-AAA-0056 Unable to authenticate

    CAM-AAA-0170 The user is not authenticated to Netegrity Siteminder

    CAM-AAA-0167 Unable to retrieve SSO token or SM session specification

     

    Has anyone had a similar issue with a resolution? 



  • 2.  Re: Issues with Cognos/siteminder integration

    Posted 11-22-2017 10:40 AM

    It says unable to decode the SSO Token. Was the KEYS (Agent Key and Session Key on CA SSO Policy Server) updated ?



  • 3.  Re: Issues with Cognos/siteminder integration

    Posted 11-22-2017 11:12 AM

    The keys were not updated.



  • 4.  Re: Issues with Cognos/siteminder integration
    Best Answer

    Posted 11-30-2017 01:45 AM

    Hi ,

     

    Refer : Issue decoding SMSession Token in Cognos with Siteminder SDK Agent 

     

    You need to have the SDK Agent running in the same FIPS Mode as the Web Agent and Policy Server. Since the Web Agent is running in FIPS_ONLY, the SDK Agent will need an Environment Variable to know what FIPS Mode it should be in.

     

    Regards,

    Leo Joseph.