Layer7 API Management

Expand all | Collapse all

Inactivity timeout period for Policy Manager

Jump to Best Answer
  • 1.  Inactivity timeout period for Policy Manager

    Posted 05-25-2017 11:10 AM

    When I set inside the preferences the inactivity timeout period as 0, the gateway still disconnects eventually. Here (https://docops.ca.com/ca-api-gateway/9-2/en/learning-center/overview-of-the-policy-manager/preferences), it's mentioned that by setting the value 0, the timeout gets disabled. Could there be another issue? For the other values (between 1-60), it works OK.

     

    Best regards,

    Panagiotis

     

    Panagiotis Karanikas

    Associate Services Consultant



  • 2.  Re: Inactivity timeout period for Policy Manager
    Best Answer

    Posted 05-25-2017 07:20 PM

    Hello karpa08 ,

    The connection can be closed on client side or server side, the PM setting is just for client side, on gateway side, navigate to menu "Tasks" > "Users and Authentication" > "Manage Administrative User Account Policy" > set "Gateway Session Expiry" to a value you prefer (1~1440 minutes)

    For older version of CA API Gateway (9.0 or below), the menu path should be "Tasks" > "Manage Account Polices" > "Manage Administrative User Account Policy"

     

    Regards,

    Mark



  • 3.  Re: Inactivity timeout period for Policy Manager

    Posted 05-26-2017 05:39 AM

    Hi Mark,

     

    Thanks for the reply. It seems that this was the issue.

     

    Best regards,

    Panagiotis