Layer7 API Management

Expand all | Collapse all

API Gateway version required for installation of MAG

Jump to Best Answer
  • 1.  API Gateway version required for installation of MAG

    Posted 04-27-2017 10:23 AM

    Hello,

     

    It is mentioned within this page (https://docops.ca.com/display/MAG40/Prepare+for+Installation), that before installing MAG, the gateway should be upgraded to 9.2.

     

    I have already installed OAuth Toolkit 4.0 even if I use the Gateway version 9.1. Is it absolutely necessary to have Gateway 9.2 for MAG 4.0? In that case, I guess I should choose the MAG 3.3.

     

    Thanks in advance.

     

    Best regards,

    Panagiotis



  • 2.  Re: API Gateway version required for installation of MAG
    Best Answer

    Posted 04-27-2017 10:50 AM

    Hi Panagiotis,

     

    OTK 4.0 also requires Gateway 9.2. Below is our official supported versions.

     

     

    https://docops.ca.com/display/MAG40/Release+Notes
    https://docops.ca.com/display/OTK40/Release+Notes

     

    Regards,

    Joe

     



  • 3.  Re: API Gateway version required for installation of MAG

    Posted 04-28-2017 10:34 AM

    Hi Joe,

     

    Thanks for the response.

    Nevertheless, I have already combined OTK version 4.0 with Gateway 9.1 and MAG 3.3 and trying to see if I can use all the available functions, before I need to upgrade the Gateway.

     

    I have no problem in using the test clients, however when I try to access https://target.ca.com:8443/auth/oauth/v2/authorize/login  (target.ca.com is my host name), I receive the error:

     

    OAuth 2.0 Authorization Server

    error: invalid_request
    error_description: Missing or duplicate parameters

     

    I have found that in OTK 3.5, the problem was usually the value for otk_session_secret_encryption that needs to be exactly 256 bit was hyphenated and that it had to be modified. However, in OTK 4.0 this issue seems not to exist, as there are no hyphens in the value and anyway the policy cannot be modified, at least to my understanding.

     

    Do you have maybe some idea what could be the problem (in case that Gateway 9.1 can cooperate with OTK 4.0).

     

    Best regards,

    Panagiotis



  • 4.  Re: API Gateway version required for installation of MAG

    Posted 05-01-2017 04:15 PM

    Hi Panagiotis,

    OTK 4.0 is a major release (3.x to 4.x) that works on Gateway 9.2. MAG 4.0 is the corresponding major release for the Mobile API Gateway. The 4.0 releases provide a baseline that simplifies future upgrades, separating customer customization from policy updates and bug fixes. As you have noticed, this includes read-only policies.

    Using OTK 4.0 with Gateway 9.1 is not supported. It is untested. MAG 3.3 is not compatible with OTK 4.0. 

     

    Simon



  • 5.  Re: API Gateway version required for installation of MAG

    Posted 05-04-2017 04:08 AM

    Hi Simon,

     

    Thank you for the information regarding the compatibilities among them.

     

    Cheers,

     

    Panagiotis