DX Infrastructure Management

Expand all | Collapse all

Fail to discover only 2 AIX servers with rsp probe

  • 1.  Fail to discover only 2 AIX servers with rsp probe

    Posted 09-05-2017 10:53 AM

    Hi there.

    So, I'm trying to discover 2 aix servers, in both cases I get "error" from the rsp discovery window.

     

    The log from rsp.log is the follow:

     

    Sep  4 12:04:45:014 [7824] rsp: run_command_Others: - Command Timeout

    Sep  4 12:04:45:014 [7824] rsp: run_command_Others: Received an error - 3. Raising Alarm

    Sep  4 12:04:45:014 [7824] rsp: run_data_gathering: Failed to execute command /usr/local/bin/pbrun uimssh /usr/sbin/sar -P ALL 1 2

    Sep  4 12:04:45:014 [7824] rsp: discover_cpu: (xxxxxxxx) ERROR no output from data collection command /usr/local/bin/pbrun userid /usr/sbin/sar -P ALL 1 2

    Sep  4 12:04:45:014 [7824] rsp: discover_cpu: Performing cleanup for the discover_cpu command

    Sep  4 12:04:45:014 [7824] rsp: CPU cannot be discovered for host '******'

    Sep  4 12:04:45:014 [7824] rsp:  Time taken in discovering ******=403

     

    I can connect with the user in the server, and I can ran the command properly with an output. It only happens when I'm trying to discover, and it only happens with these two servers, I have several servers with the same configuration and they were discovered just fine.

     

    Any ideas?

     

    thanks in advance



  • 2.  Re: Fail to discover only 2 AIX servers with rsp probe

    Posted 09-05-2017 10:56 AM

    Please open a case with support this is probably an issue of the discovery timing out.

    There is new fix for this that has not gone GA.

    do double check the sshd_conf file on the systems just to make sure they are the same as the working.



  • 3.  Re: Fail to discover only 2 AIX servers with rsp probe

    Posted 09-05-2017 11:07 AM

    Alright, I will open a case then.

     

    Ehm, the sshd_conf files are illegible, all I get is NULL characters with randome legible characters in the middle (perhaps I'm doing it wrong).



  • 4.  Re: Fail to discover only 2 AIX servers with rsp probe

    Posted 09-05-2017 11:10 AM

    Do make sure you can connect using putty from the robot machine using the same user name and password

    as you are using in RSP.

    If you can not do this work with the system admin to correct this first.



  • 5.  Re: Fail to discover only 2 AIX servers with rsp probe

    Posted 09-05-2017 11:20 AM

    Ok, from two servers where I have rsp probes, I tried to connect to one of the AIX servers and it connect perfectly and also I could run the command and get output.

    Also did the same test from the main UIM server.