Symantec Access Management

Expand all | Collapse all

Tech Tip : CA Single Sign-On : Policy Server Data Import fails with Failed updating RootConfig Object Error

  • 1.  Tech Tip : CA Single Sign-On : Policy Server Data Import fails with Failed updating RootConfig Object Error

    Broadcom Employee
    Posted Sep 20, 2016 07:22 AM

    Issue :

     

      Importing data into a new Policy Store instance
      configured for 12.52SP1CR05, then the import
      command fails with the error :

     

      ERROR: Failed updating RootConfig object
      1c-67b3c2b0-9e28-11d3-95e7-00c04f7468ef.
      Status: 'Unknown Failure'

     

    Environment :

     

       Policy Server 12.52SP1CR05 on SunOS 5.10;
       Policy Store : RDBMS Oracle 11
     
    Cause :

     

     Basically, the import command fails because the RootConfig
     object has a property which exceeds a size limit. The DynamicPrefs
     shouldn't be more than 1024 characters. If the DynamicPrefs attribute
     is over 1024 characters, the import will fail.

     

    Resolution :

     

       The solution is to remove all the unnecessary administrator from
       from the Database in order to have DynamicPrefs less than 1024 characters.
       You might also use the XPSExplorer to do it in the Policy Server from
       which you exported the data first.



  • 2.  Re: Tech Tip : CA Single Sign-On : Policy Server Data Import fails with Failed updating RootConfig Object Error

    Posted Sep 28, 2016 02:55 AM

    Even if we remove the unnecessary Administrators in our case the dynamicprefs value was same and there was no change, after taking the export.  so we increased the DynamicPrefs column value from 1024 kb to 3120 kb in Schema using SQL Developer, as maximum we can give upto 4000, hence no harm in increasing, we already running this configuration in pre-production since long back. But when it comes to production we have kept the default value what CA has shipped with.