Service Virtualization

Expand all | Collapse all

Lisa Invoke API issue.

Jump to Best Answer
  • 1.  Lisa Invoke API issue.

    Posted 02-28-2018 04:24 PM
      |   view attached

    I am trying to manage my Virtual services by using Lisa Invoke API.


    Below are the steps I have performed.


    1. I have added below property into file in my local machine.

         ( lisa.invoke2.swagger.basepath=http://registryname:1505/api/Dcm)

    2. accessed API url  http://registryname:1505/api/swagger/ in browser.

    3.  Page loaded with list of options.

    4. I want to start/stop one of the virtual service(ABC) which was deployed into VSE.


    Now my questions are,

    1. I want start/stop my virtual service which was deployed into VSE. which option should I select?

    ex. start a virtual service in a VSE?

    2. I think we should add below path into VSE server side?    lisa.invoke2.swagger.basepath=http://registryname:1505/api/Dcm

    3. I have selected Stop a virtual Service in a VSE. where we need to provide service name and Virtual service name.

       could some one suggest what is the service name and VSname here?

  • 2.  Re: Lisa Invoke API issue.
    Best Answer

    Posted 02-28-2018 05:06 PM

    ServiceName is used in the event your installation has more than one VSE service running under a Registry. Most likely the name of the VSE is "VSE" which is the default. To verify your service name, access the Portal, CLICK Monitor, Under Virtual Service Environments select the one you want to use:

     POST /VSEs/VSE/{virtualServiceName}/actions/stop

    virtualServiceName is the name of the virtual service.  In the below example, fakeResponder would be used.





    Returns (edited):

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <Vse xmlns=""
          name="VSE" xmlns:xsi=""

          <VirtualServiceList href="http://localhost:1505/api/Dcm/VSEs/VSE"       type="application/">
             <VirtualService name="fakeResponder"
                href="http://localhost:1505/api/Dcm/VSEs/VSE/fakeResponder"             type="application/">


                <Link href="http://localhost:1505/api/Dcm/VSEs/VSE/fakeResponder/actions" rel="down"/>
                <Link href="http://localhost:1505/api/Dcm/VSEs/VSE/fakeResponder/actions/start" rel="start"/>
                <Link href="http://localhost:1505/api/Dcm/VSEs/VSE/fakeResponder/actions/stop" rel="stop"/>
                <Link href="http://localhost:1505/api/Dcm/VSEs/VSE/fakeResponder/actions/resetCounts" rel="resetCounts"/>


  • 3.  Re: Lisa Invoke API issue.

    Posted 03-01-2018 09:45 AM

    Hi Joel,

    Thanks for the reply.


    I have tried to stop the virtual service by using IE(updated localhost and Virtual service name). But got a error message.


    Error Message:

    1008Method Not Allowed at com.sun.jersey.server.impl.uri.rules.TerminatingRule.accept( at com.sun.jersey.server.impl.uri.rules.ResourceClassRule.accept( at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept( at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept( at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest( at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest( at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest( at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest( at com.sun.jersey.spi.container.servlet.WebComponent.service( at com.sun.jersey.spi.container.servlet.ServletContainer.service( at com.sun.jersey.spi.container.servlet.ServletContainer.service( at javax.servlet.http.HttpServlet.service( at at at at at at at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter( at com.itko.lisa.invoke.AuthenFilter.doFilter( at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter( at org.eclipse.jetty.servlet.ServletHandler.doHandle( at org.eclipse.jetty.server.handler.ScopedHandler.handle( at at org.eclipse.jetty.server.session.SessionHandler.doHandle( at org.eclipse.jetty.server.handler.ContextHandler.doHandle( at org.eclipse.jetty.servlet.ServletHandler.doScope( at org.eclipse.jetty.server.session.SessionHandler.doScope( at org.eclipse.jetty.server.handler.ContextHandler.doScope( at org.eclipse.jetty.server.handler.ScopedHandler.handle( at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle( at org.eclipse.jetty.server.handler.HandlerWrapper.handle( at org.eclipse.jetty.server.Server.handle( at org.eclipse.jetty.server.HttpChannel.handle( at org.eclipse.jetty.server.HttpConnection.onFillable( at$ReadCallback.succeeded( at at$ at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.executeProduceConsume( at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceConsume( at at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob( at org.eclipse.jetty.util.thread.QueuedThreadPool$ at


    please advise how to perform post call using invoke API.


    Note: Get calls are working as expected.

  • 4.  Re: Lisa Invoke API issue.

    Posted 03-01-2018 10:36 AM

    I tried in POSTMAN and its working as expected.


    Thank you,


  • 5.  Re: Lisa Invoke API issue.

    Posted 03-01-2018 02:36 PM

    Hi Joel,


    as you suggested, I have tried POST and GET methods and working as expected.

    buy when I tried to set Execution mode (PUT Method) getting bad request error. Below are the request details.

    Referred document url:






    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>

    <VirtualService xmlns="" name="VirtualServiceName"
     xmlns:xsi="" xsi:schemaLocation=" VirtualService.xsd"  href="http://Regitryname:1505/api/Dcm/VSEs/VSE/VirtualServiceName"
     <ExecutionMode>Transaction Tracking</ExecutionMode>



    Error details:

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <Error xmlns="" xmlns:xsi="" xsi:schemaLocation=" Error.xsd" type="application/">
        <Message>Bad Request</Message>

    Please provide solution.




  • 6.  Re: Lisa Invoke API issue.

    Posted 03-01-2018 03:51 PM

    There may be a bug in the code or in the documentation.  I am not sure. May be best to open a ticket with CA Support.

    What did you pass in the HTTP headers? The information sent seems to be based on the response headers from:

    GET http://<registry>:1505/api/Dcm/VSEs/VSE/<serviceName>

    PUT http://<registry>:1505/api/Dcm/VSEs/VSE/<serviceName>

    http header -> ContentType = application/

  • 7.  Re: Lisa Invoke API issue.

    Posted 03-01-2018 04:14 PM

    I have added below details in header details.


    Content-Type = application/


    will open support ticket.