DX Application Performance Management

Expand all | Collapse all

10.5 java agent for websphere portal server 8.5

Jump to Best Answer
  • 1.  10.5 java agent for websphere portal server 8.5

    Posted 02-20-2018 01:45 PM

    Does anyone have good instructions for the 10.5 java agent install/configuration for Webster portal server 8.5? ##caapm #apmintroscope



  • 2.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-20-2018 02:19 PM

    Greg --

    I am not able to find  any instructions for 10.5 but there are some instructions available in 10.2. it will help  you configuring your portal.

     

    https://docops.ca.com/ca-apm/10-2/en/extending/ibm-websphere-portal/installing-and-configuring-the-ca-apm-for-ibm-websphere-portal



  • 3.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-20-2018 02:24 PM

    yes, while that might be helpful, there is also a ca marketplace implementation that has minimal instructions and assumes some things.  So I am not able to find a complete instruction guide for setting up the 10.5 agent for websphere portal 8.5. 



  • 4.  Re: 10.5 java agent for websphere portal server 8.5
    Best Answer

    Posted 02-20-2018 02:47 PM

    The ZIP has two components: EM plugins, agent plugins (tarball & zip).

     

    EM plugins has a TXT file in the directory with instructions.

     

    For the agent, just unzip/untar directly into your existing agent installation, making sure things are place in the right folders.

     

    Both EM and agents will need to be restarted.



  • 5.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-21-2018 05:11 AM

    Let's say the question is that I don't have an existing agent installation and my current APM envrionment is 10.5.1.  Let's start from scratch.  Now which agent do I install before I follow those instructions?  Do I go back to the 10.2 legacy no-installer and try to follow those instructions to install the agent or do I install a regular 10.5.1 java agent?  



  • 6.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-21-2018 10:41 AM

    As the README states, the only thing that was done was to update the extension to use New Mode tracers.

    You can just deploy it with any recent version of the WAS agent that is compatible with your EM version.



  • 7.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-21-2018 11:18 AM

    Okay, so I had opened a ticket regarding this as well as asking the community.  The answer I just got back from Support is the following. 

    We need to use the IntroscopeAgentFiles-Legacy-NoInstaller for APM release 10.2 and then add the extension. APM agent release 10.2 can report to your APM 10.5.1 environment. APM agent release 10.5 is not certified and supported for websphere portal.



  • 8.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-21-2018 11:43 AM

    So, the readme seems to indicate that it was a 10.5 java agent that the extension can be deployed to or older and it was only tested with 9.7, but support indicates that you should still be using the 10.2 legacy-noinstaller implementation.  Then the readme is also confusing regarding the manual directions as it talks about new mode, deploying on 10.5 and doing nothing, but 10.3 & earlier modifying the directives.  I had just hoped that someone had actually done this and could recommend somewhat of a best practice implementation with a few more details.



  • 9.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-20-2018 02:53 PM
      |   view attached

    Here is the README

    Attachment(s)

    zip
    README.md.zip   1K 1 version


  • 10.  Re: 10.5 java agent for websphere portal server 8.5

    Posted 02-21-2018 12:27 PM

    Hello Greg,

    I haven't implemented it in anger, but I'd like to clear up the agent versioning, at least try to clear things up..

     

    We would say to use 10.2 legacy agent as it would be the last version of the agent that would supply the WebSphere Portal monitoring out-of-the-box. That version of the extension to monitor WAS Portal was not updated to agent new mode.

     

    The extension you get from CA Marketplace is a port of the extension to new mode, as the description on marketplace says:

    "Migration of product version of PowerPack for WebSphere Portal to HC (agent new mode) version. No features added or removed."

     

    That marketplace version could therefore be used with the normal agent, no reason it could not be used with 10.5 but it won't have been worked on with Team Center in mind for example.

     

    We should also state the updated extension is not supported by support itself, whereas I would have to be honest and suggest the 10.2 legacy extension should still be supported by support.

     

    All I remember from the implementation is you need to put pbd/pbls in the core/config folder and specify in the agent profile, and add the agent jar file to the /core/ext folder.

    A while ago, it used to be necessary to copy the agent extension jarfile to the /shared/app folder (or similar name) into the WAS Portal install itself, but that requirement was removed in any option that is currently available.

     

    According to the 10.2 compatibility guide, it does support Portal 8.5.

    The other question could be about support for release 10.2, all I can say is we still list support for 9.7 so I'd like to anticipate there would still be a few years before 10.2 is out of support.

     

    Thanks,

    David