Layer7 Access Management

Expand all | Collapse all

WebAgent Configuration: Incorrect Path

Jump to Best Answer
  • 1.  WebAgent Configuration: Incorrect Path

    Posted 12-23-2016 03:13 PM

    Hello,

     

    I receiving the following error when starting the WebAgent.  It's looking for httpd in the wrong path, but I cannot locate appropriate config file to update.  Can anyone point me in the right direction?

     

    [23/Dec/2016:14:48:42] [Error] SiteMinder Agent
    Failed to Start the LLAWP process.
    LowLevelAgent.LLAWPExec.Failed (Invalid argument)
    nm: '/etc/httpd/bin/httpd': No such file

     

    Using Apache 2.4 on RHEL7

    smwa-12.52-sp01-cr04

     

    Thanks,

    Charles



  • 2.  Re: WebAgent Configuration: Incorrect Path

    Posted 12-27-2016 09:25 PM

    Hi, there could be multiple reasons why your apache would not startup with that message.

     

    I did a quick research and could find following reasons.

     

    1. All the configuration files(httpd.conf, WebAgent.conf, SmHost.conf and etc) are not owned by the user you are using to startup the web server. Instead, they are owned by a group which the user belongs to.

    ==> Try using changing the ownership of the files instead of using group ownership

     

    2. Some intelligent tools were used to install/configure the web server forcing the web server worker mode to prefork mode.

    ==> Try using original httpd.conf file and use the agent configuration wizard only to configure the agent.

     

    3. Non-supported environment.

    ==> WebAgent version and the OS was not supported configuration.

     

    It would be good to open a support ticket with "strace" data if you want to dive deeper.

     

    strace -Ff -t -i -v -o strace. log -s 16384 ./apachectl start

     

    This would generate a HUGE strace.log file(it could be couple of gigabyte or more).

     

    Then locate the "LowLevelAgent.LLAWPExec.Failed" message and track backwards to see if there are meaningful message that might explain why there is an error.

     



  • 3.  Re: WebAgent Configuration: Incorrect Path

    Posted 05-11-2018 12:01 PM

    Hi,

     

    I also have the same issue, but apparently the agent is running fine (no other errors).

    This error is shown on Apache 2.4 "error_log" file.

     

    I have searched for other situations where the error has occurred and found these:

    Tech Tip : CA Single Sign-On :Web Agent : How to troubleshoot agent initialization issues 

    Unable to start webagent 

    Cannot start LLAWP on RHEL7/Apache 2.4 

     

    It seems that the web agent is trying to execute the shell command "nm" with the parameter "/etc/httpd/bin/httpd".

    Is this something that only happens with Apache 2.4 installations?

    Is there a way to check why is the web agent trying to run the "nm" command and why is it using that that path?

     

    I am using web agent 12.51 CR10 on a Red Hat 7 with an embedded installation of  Apache 2.4  (red hat standard httpd for this system).

     

    Thanks.



  • 4.  Re: WebAgent Configuration: Incorrect Path
    Best Answer

    Posted 05-11-2018 02:05 PM

    I figured out the solution to the problem...

    The web agent tries to find the the "httpd" binary by following the {ServerRoot}/bin path which is defined in apache 2.4  (embedded RHEL 7 version) as:

    ServerRoot "/etc/httpd"

     

    So, on RHEL 7 you might need to create a symbolic link :

    ln -s /usr/sbin /etc/httpd/bin

     

    However, after this, the error will probably change to:

    nm: /usr/sbin/httpd: no symbols

    And the solution would be to compile your own Apache to get symbols on the binary, as stated here:

    Tech Tip : CA Single Sign-On : When doing Apache graceful restart, Web Agent reports error "PID Cache error" 

     



  • 5.  Re: WebAgent Configuration: Incorrect Path

    Posted 05-14-2019 12:32 AM

    The "nm" command was run on startup on the httpd binary as part of a fix so the agent could determine if the restart opiton could be used for apache/webagent (there was some bug when restart was performed, and this nm test was added to detect that condition). 

     

    In the first installed version with that fix if it failed to run the nm command the agent would give the error and then fail.  Later versions (R12.52 Sp1 CR9 at least) when it does not find the binary it will give a different message - not a failure just a warning : 

     

    [14/May/2019:00:17:56] [Error] SiteMinder Agent
    Failed to initialize the configuration manager.
    LLAWP unable to get configuration, exiting.
    nm: '/etc/httpd/bin/httpd': No such file
    [Tue May 14 00:18:01.059561 2019] [sm:warn] [pid 2991] Siteminder Web Agent: restart not supported.

     

    So if you encounter this error, and it is failing, then latter version of the agent is probably what you need. 

     

    Cheers - Mark