Clarity PPM

Expand all | Collapse all

Xog Write error in 15.2

Jump to Best Answer
  • 1.  Xog Write error in 15.2

    Posted 03-01-2018 04:02 AM

    Hello Team,

     

    We have just upgraded Dev and UAT environments from 13.3 to 15.2 Patch 3 and now getting some issue while Doing Xog write operation of process xml file. We are following steps -

    1) Read the process xog file from Dev environment in XOG client via

     

     <?xml version="1.0" encoding="UTF-8"?>
    <NikuDataBus xsi:noNamespaceSchemaLocation="../xsd/nikuxog_read.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Header externalSource="NIKU" objectType="bpm_process" action="read" version="8.0"/>
    <Query>
    <Filter criteria="EQUALS" name="process_code">process_code</Filter>
    </Query>
    </NikuDataBus>

     

    2) Copy the result and removed <XOGOutput> section at the end of file and paste it in XOG Client of UAT environment but getting below error -

     

    <?xml version="1.0" encoding="UTF-8"?>
    <XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd">
    <Object type="unknown"/>
    <Status elapsedTime="0.0 seconds" state="FAILURE"/>
    <Statistics failureRecords="0" insertedRecords="0" totalNumberOfRecords="0" updatedRecords="0"/>
    <ErrorInformation>
    <Severity>FATAL</Severity>
    <Description>Exception while processing client request</Description>
    <Exception type="com.niku.xog.XOGException">org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 2; Reference is not allowed in prolog.</Exception>
    </ErrorInformation>
    </XOGOutput>

     

    3) We have performed same Xog Read & Write operation for Resource object in xog Client and it ran without any issues or Errors.

    4) Process Xog write operation is failing in both Dev and UAT 15.2 environments.

     

    Somebody also raise this error in Strange behavior of XOG interface (reference is not allowed in prolog, login failed, XOG invoke failed...)  but Solution is still unknown.

     

    Please suggest your comments and feedback.



  • 2.  Re: Xog Write error in 15.2

    Posted 03-01-2018 04:33 AM

    So did you try removing

    <?xml version="1.0" encoding="UTF-8"?>



  • 3.  Re: Xog Write error in 15.2

    Posted 03-01-2018 05:40 AM

    Yes but no success. same error is coming.



  • 4.  Re: Xog Write error in 15.2

    Posted 03-02-2018 01:20 AM

    You have declared your xml's encoding UTF-8.  Make sure you don't have a (byte order mark) BOM as the first character of the xml.

     

    V/r,

    Gene



  • 5.  Re: Xog Write error in 15.2
    Best Answer

    Posted 03-09-2018 03:43 AM

    This issue is occurring when i tried to run Xog write request from Xog client URL and root cause is still unknown to me. But when i ran the same via command prompt, it worked fine.



  • 6.  Re: Xog Write error in 15.2

    Posted 03-09-2018 04:01 AM

    When you say
    Xog client URL

    do you mean the HTML portled which was dropped from CA PPM, a similar third party portlet or something else?



  • 7.  Re: Xog Write error in 15.2

    Posted 03-09-2018 04:06 AM

    Yes Urmas. I think it was not dropped. Only disabled from config. We can enable it if need. It working fine in 13.3.