Service Virtualization

Expand all | Collapse all

Think-Time in MQ

Jump to Best Answer
  • 1.  Think-Time in MQ

    Posted 09-25-2017 05:51 AM

    Hi,

    I am unable to apply think-time in responses of MQ service. Same is working in SOAP services, but not getting delayed response for MQ.

     

    Version :- 9.5.1

     

    Please help if someone has faced similar issues,

     

    Thanks,

    Dinesh Kumar



  • 2.  Re: Think-Time in MQ

    Posted 09-25-2017 11:26 AM

    Are you using the old 'IBM MQ Series' protocol or the newer 'IBM MQ Native'?

     

    With the old protocol there are caveats with delayed responses, and things you need to do to enable it.  You must have a single, static response queue, no temp queues or multiple response queues.  If that's the case, then you need to edit the 'Respond' step and check the 'Share sessions' checkbox to enable it.

     

    With the new protocol it should work out of the box.  If it's not working for you then make sure you have the think time declared in the service image response, and that you're not deploying with 0% think time.  If none of that works then it sounds like a bug.



  • 3.  Re: Think-Time in MQ
    Best Answer

    Posted 09-25-2017 04:18 PM

    Customer opened the issue 00850202, it looks like a bug in 9.5.1.