DX Infrastructure Management

Expand all | Collapse all

SuperPackage Issue

  • 1.  SuperPackage Issue

    Posted 09-15-2017 07:12 AM

    Hi,

    I have created a superpackage for Linux OS and I tested in one machine it was successful but when I deploy same package on another machine I am getting an error as "Dependency referenced not found(package<packagename>, section=CDM)" . Please let me know what may be wrong in the package which I have created.



  • 2.  Re: SuperPackage Issue

    Posted 09-15-2017 08:21 AM

    The message you provided would suggest the target system does not already of the cdm probe installed on it.

    for more details you can set the target controller loglevel to 3 and logsize to 5000 and then on the distsrv set the loglevel to 5 and logsize to 35000 and recreate the problem then check the two log files for details on why it is failing.

     

    Hope this helps



  • 3.  Re: SuperPackage Issue

    Posted 09-19-2017 10:27 AM

    Thanks Friend for you reply.

    You are correct, but I added probes into that package. Still I was getting error.

    Now issue is fixed, I did a mistake while updating the dependency so I was getting error.

    Thanks again.



  • 4.  Re: SuperPackage Issue

    Posted 09-15-2017 11:07 AM

    What is the content of your superpackage? As Gene_Howard mentioned, if your superpackage is a configuration pacakge and you put a dependency check for CDM in there, if you try to push it on a server, it needs to install CDM on the target machine if it's not there already. The issue you face is probably that you have secondary hubs and archive on these secondary hubs, correct? If you push the superpackage on a robot which is attached to a secondary hub embedding archives, the deployment will be pushed by distsrv on the secondary hub. If the CDM package isn't present in the secondary hub archives (or if the version is incorrect) you will get that kind of error. Double check the cdm package is present in the archive of the hub the robot you're targeting is attached to connecting with IM directly on that hub. If the cdm pacakge is missing, add it into this archive repository and try again your superpackage deployment. That should work! 



  • 5.  Re: SuperPackage Issue

    Posted 09-19-2017 10:36 AM

    Thanks Friend for you reply.

    CDM package is present in secondary hub as well but the issue was due to my mistake, i updated dependency wrongly so i was getting error. there was a typo error. Issue is fixed now.

    Thanks again.



  • 6.  Re: SuperPackage Issue



  • 7.  Re: SuperPackage Issue

    Posted 09-19-2017 10:38 AM

    Thank you, i was following the same procedure but due to small mistake in dependency section i was getting this error.

    Issue is fixed now friend.

    Thank you