IT Process Automation

Expand all | Collapse all

Run SSH Command Operator Fails

Jump to Best Answer
  • 1.  Run SSH Command Operator Fails

    Posted 10-24-2016 03:48 PM

    I have to trigger the script placed on the Linux Server. On connecting manually via Putty, it is working fine. But when I run it using the operator, it gots failed and the Reason contains our command that I provided using Pre-Execution of the operator.

    Kindly help me out if anyone have some information regarding this issue.



  • 2.  Re: Run SSH Command Operator Fails

    Posted 10-25-2016 09:49 AM

    If you remove the pre-execution code, does it work?  If the pre-execution code is returning an error, then it isn't getting to the script yet and you will need to figure out what is wrong with the pre-execution code.  You can post the error here which might clarify what the problem is.



  • 3.  Re: Run SSH Command Operator Fails

    Posted 10-25-2016 04:02 PM

    Hello Andrew Thompson

    The pre-execution code is working fine. The command that I run using the "Run SSH Command" operator, gets executed on the target Server. But the output of the script is not coming in the SSHCommandsOutput[] variable, which is there when I run the same command using putty. I am facing this type of problem on some flavours of Unix. On some servers it is working fine, but for others it is not working as it should do. Kindly let me know if I missed some settings or something else.

    Thanks in advance.

    Ankur Gupta



  • 4.  Re: Run SSH Command Operator Fails
    Best Answer

    Posted 11-01-2016 08:18 AM

    Without the actual error message it makes it difficult to know what the problem might be.  If this command works on certain Unix machines and not on others, it might be an SSH config issues.  You might compare the sshd.conf file on your Unix systems to see what might be different.  I do know that the blowfish cipher is necessary for PAM to communicate via SSH.  Here is a knowledge doc on that:

     

    Knowledge Base Articles