Service Virtualization

Expand all | Collapse all

Getting error "Unrecognized SSL message, plaintext connection?"

Jump to Best Answer
  • 1.  Getting error "Unrecognized SSL message, plaintext connection?"

    Posted 10-05-2016 03:41 PM

    I am very basic to service virtualization. We are trying to Virtualize a service with https(Examplehttps://internal-sales/Sales/.svc). But the wsdl of this service has http(Example: https://internal-sales/Sales/.svc?wsdl).

     

    We recorded the service and checked 'Use SSL to server' and 'Use SSL to Client' while recording(The recording did not happen until both options are checked. 

     

    After the virtual image and model file are created, we deployed it to server.

     

    Now, if we are hitting the URL with https, its giving error "javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?", where as it works fine with http. 

     

    Could some one please help me out with this?



  • 2.  Re: Getting error "Unrecognized SSL message, plaintext connection?"

    Posted 12-19-2017 08:29 AM

    Hi,

     

    This is happening to me too, but in the case of the UIM integration with APM.

    They managed to solve this issue?

     

    Thanks,

    Richard



  • 3.  Re: Getting error "Unrecognized SSL message, plaintext connection?"
    Best Answer

     
    Posted 12-19-2017 10:10 AM

    Hi, 

     

    To send the request to the Virtual Service use HTTP and not HTTPS. 

     

    Regards,

    Francis