DX Infrastructure Manager

Expand all | Collapse all

Experiencing Issue in configuring Azure probe

  • 1.  Experiencing Issue in configuring Azure probe

    Posted 03-07-2017 06:03 PM

    I am trying to test CA UIM Azure probe 3.01 in our UIM 8.47 environment using my trial Azure subscription.

     

    I have used following documentation to configure my Azure probe:

     

    Azure AC Configuration - CA Unified Infrastructure Management Probes - CA Technologies Documentation

     

    azure (Microsoft Azure Monitoring) Release Notes - CA Unified Infrastructure Management Probes - CA Technologies Documen… 

     

    Create identity for Azure app in portal | Microsoft Docs 

     

    I deployed the azure probe and have updated user and password information in the azure.cfg using raw configure. 

     

    I created Azure profile by copying and pasting Subscription IDAD Directory ID,Application ID and Client Secret detail from Azure portal, but for some reason I am constantly getting following error when I try to verify my new Azure profile:

     

    Unable to connect to the requested subscription. Please verify the credentials and try again.

     

    Also one thing I am not certain is the IP address info in azure.cfg. Does anyone know which IP address does it refer to?

     

    Anyway, Can anyone provide me some guidance as how to configure Azure probe? 

     

     

    Kind regards

     

    Alex



  • 2.  Re: Experiencing Issue in configuring Azure probe

    Posted 03-08-2017 04:25 AM

    Hello. Alex.

    Please confirm if you have completed "Assign application to role".

    Create identity for Azure app in portal | Microsoft Docs 

    Regards,

    Yu



  • 3.  Re: Experiencing Issue in configuring Azure probe

    Posted 03-08-2017 08:43 AM

    Important here to note that in Step 6 of the guide, you have to manually type in the name of the ad application you created. Only then you will be able to select it from the list. Once this has been done, please try to verify the subscription again in the probe.

     

    The configuration of the probe is done via Admin console, please use that to add your information. The IP  refers to the Azure target environment, please do not change the IP via raw configure.

     

    Kind Regards,

     

    Martin Fink

    CA Tech Support



  • 4.  Re: Experiencing Issue in configuring Azure probe

    Posted 03-09-2017 12:27 AM

    Hi Yu & Martin

    Thank you for your response.  That is very helpful. By the way. Are you able to me if I can use azure probe to monitor azure servers metrics ie CPU, Memory, disk and window services?

     

    Regards

     

    Alex



  • 5.  Re: Experiencing Issue in configuring Azure probe

    Posted 03-09-2017 08:26 AM

    Dear Alex,

     

    here is the list of the metrics supported by the probe:

    azure Metrics - CA Unified Infrastructure Management Probes - CA Technologies Documentation 

     

    I see vm cpu, disk and memory on there but I am not sure what you mean by services. Anything not on this list is currently not available.

     

    Kind Regards,

     

    Martin Fink

    CA Tech Support



  • 6.  Re: Experiencing Issue in configuring Azure probe

    Posted 04-29-2018 04:00 PM

    Hi, 

     

    I am having the similar issue, did assign reader role to the application.

    Is the issue resolved for you Alex?

    Thanks,

    Uday