Layer7 Privileged Access Management

Expand all | Collapse all

CA PAM - Oracle Enterprise Manager SSO

Jump to Best Answer
  • 1.  CA PAM - Oracle Enterprise Manager SSO

    Posted 12-18-2017 06:42 AM

    Hello

     

    I'm trying to setup SSO on Oracle Enterprise Manager web portal (Oracle Enterprise Manager Cloud Control 12c).

    For that , I created one TCP/UDP service for it (tcp port 7301, web portal, xsuite html websso, hxxps://<Local IP>:<First Port>/em).

    When I do the learning process, it all seems to work fine. I marked the fields without any problem.

    But when I try the SSO it doesn't work. It keeps "please wait , logging in" and it times out.

    The credential are ok . I tried using the credentials on the "learning process" and I was able to login.

    Thus anyone had this problem with Oracle Enterprise Manager ? Is the a way to debug what's happening on the SSO process ?

    Thanks in advance

    Best regards



  • 2.  Re: CA PAM - Oracle Enterprise Manager SSO

    Posted 12-20-2017 02:37 PM

    Hello Nuno, We don't have a good debugging option for this case. If you were able to mark account name, password, and submit button, and configured a target account with valid username and password to logon, it should work. Could there be any other action you need to click when you logon to the web service outside of PAM, like acknowledging a message? If you continue to have problems, please open a support case.



  • 3.  Re: CA PAM - Oracle Enterprise Manager SSO

    Posted 12-21-2017 02:02 PM

    Solution is very simple, if you have device host name configured in IP address field under device option then just change it to IP address and learn the application again. This should resolve your problem. 

     

    Let me know if it helps. 



  • 4.  Re: CA PAM - Oracle Enterprise Manager SSO
    Best Answer

    Posted 12-22-2017 06:51 AM

    Hello Nuno,

     


    Xsuite HTML WebSSO is only supporting automatic login to a web portal which is employing HTML-based "input" and "button" controls e.g.

     

    To confirm this is the case in your web portal, please load the page in your native Web Browser and view the source code of the page.

     

    Please see this for further details:

    Troubleshooting Xsuite HTML WebSSO Auto-connect Method to a target web portal 

     

    Make sure that in the Learn Mode all relevant field are circled in green before saving the script.

     


    Best Regards,

     

    Andreas



  • 5.  Re: CA PAM - Oracle Enterprise Manager SSO

    Posted 04-15-2018 07:53 PM

    All

    I have a customer that is seeing the same scenario (Oracle Enterprise Manager) and we tried all steps suggested on this doc but nothing worked.

    My customer is using 13c version instead of 12c.

    Any advise will be helpful.

    Thanks

    Ilir