Clarity PPM

Expand all | Collapse all

New UX issue alert:  Error API-1005 when opening a Status Report

  • 1.  New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 01-13-2017 11:59 AM

    Hello everybody,

     

     

    Just wanted to share with you an error I had with a customer lately that may be also affecting you as well, here is the explanation and the workaround. Please note this can also be caused by other actions than the ones in STR. Hope this helps  

     

     

    Issue: PMO - New UX - Error "API-1005 : Attribute(s) 'pdfFile' specified in query parameters are not supported" when opening a Status Report, after applying Status Report Object from Content Addins -PMO

     

     

    Steps to Reproduce:

     

    1. Connect to CA PPM with new UX enabled and working fine
    2. Now go to Administration - Content Addins - PMO - Items
    3. Filter to find the Status Report Object
    4. Select it, hit Install, wait it completes
    5. Now go to New User Experience link
    6. Open a Project with some Status Reports on it
    7. Click on Status

     

    Expected Result: Page opens successfully, no error message

    Actual Result: Error message API-1005 : Attribute(s) 'pdfFile' specified in query parameters are not supported.

    Workaround:

    1. On PPM database, run:

    update ODF_CUSTOM_ATTRIBUTES

          SET API_ALIAS = 'pdfFile'

          where OBJECT_NAME = 'cop_prj_statusrpt'

          and INTERNAL_NAME = 'cop_pdf_file'

          and (API_ALIAS <> 'pdfFile'

    or API_ALIAS is null)

    ;

    1 row should be updated

    commit

    1. Restart the services on the environment


  • 2.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 01-13-2017 12:39 PM

    Thanks for sharing this with the community Nika!

    New UX issue alert:  Error API-1005 when opening a Status Report 



  • 3.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 05-25-2017 01:36 PM

    thanks! I know this is  a bit older post, but hopefully you will see my note We are just now testing the new UX. We don't use the OOTB status reports; rather, each business unit has their own custom one. So the OOTB is hidden in the Classic.  Can I still run the above update? I am getting the error in the new UX.

    Does the status report in the new UX, then not read from the project object settings? Meaning, if we have it hidden or if a user has no access to it, will it always show?

     

    Thank you,

    Lynn



  • 4.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 05-25-2017 05:25 PM

    Hi Lynn

     

    You should still be able to use the above update to fix the error I referenced, API-1005.

    However if you used Secure rights to prevent the users from seeing the OOTB Status Reports, then when they go to Project - Status - Reports they will have this error message:

     

     

     

    I don't think there will be a way for you to integrate your custom Status Report object with New UX, this would likely be a new enhancement. If you need Status Reports in UX I would probably consider using the OOTB ones in parallel if that's feasible.

     

    Hope this helps -Nika

     

     



  • 5.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 05-26-2017 08:06 AM

    Thank you Nika. Yes, I did not expect our own status reports to display in the new UX maybe someday as configuration expands.

    But, just to clarify: we are not using secured rights, rather we are using display conditions. We don't get the above error message, just the API one (I ran the script, restarted the server, and the error still shows).  Thus, does it recognize display conditions as set on the project object?

     

    Or perhaps the better question is:

      the new UX (in this case status reports) doesn't read any settings from the project object?

    • I am thinking as the design progresses (Roadmap), will it ever?  A lot of long term clients have plenty of ootb fields (and subpages) that are not used, and perhaps had to use custom fields to suit their business needs. 

     

    Thanks again

    Lynn



  • 6.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 06-13-2017 03:02 PM

    Is this issue fixed in a future release (e.g., 15.3)?  I'm fine running the SQL workaround... but just curious.



  • 7.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 06-13-2017 03:08 PM

    Hi Peter

     

    I just checked and the issue should be resolved in 15.2. and higher -Nika



  • 8.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 06-13-2017 03:11 PM

    I'm still seeing the issue in 15.2.0.1



  • 9.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 06-13-2017 03:48 PM

    This is odd, we may have to open a Support issue and check it out.

    What are the results of this select statement:

    select API_ALIAS from ODF_CUSTOM_ATTRIBUTES

          where OBJECT_NAME = 'cop_prj_statusrpt'

          and INTERNAL_NAME = 'cop_pdf_file'

    Thanks -Nika



  • 10.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 06-13-2017 04:05 PM

    I'm going to make things more complicated.  We've made some Siteminder changes in our DEV environment so that the New UX works correctly.  We've also upgraded DEV to 15.2.0.1.  I've already applied the SQL workaround to the DEV environment, so there is no issue anymore.  Our other lower environments have been upgraded to 15.2.0.1, but do not yet have the Siteminder upgrade, so I can't properly navigate through the New UX yet.  When I run the query in another lower environment, I do get the result (pdfFile).  When we upgrade our Siteminder in another lower environment, I will let you know what I find....

     

    For the record, our PROD environment, which is only on 15.2 (no patch), does return the result (pdfFile)



  • 11.  Re: New UX issue alert:  Error API-1005 when opening a Status Report

    Posted 02-09-2018 05:15 AM

    Hi Nika.

     

    Upgraded from 14.3 to 15.3. We have a similar issue in the new UX, trying to open a project, we have the msg: <API-1005:Attribute(s) 'reportstatus' specified in query parameters are not supported>.

     

    We will apply path 2 and upgrade addins to see (admin content pbk, csk...).