Clarity PPM

Expand all | Collapse all

Jaspersoft Instability Since Moving to 14.3

  • 1.  Jaspersoft Instability Since Moving to 14.3

    Posted 06-28-2016 12:57 PM

    We are On Demand and We've been experiencing a number of issues since moving to 14.3 (patch 05) on Jaspersoft, and perhaps there are ways to fix the issues.  We found 14.2 to be stable, but wanted some of the dashboard features that came with 14.3. 

     

    We aren't using IE.

     

    Our first issue is that we intermittently receive errors on OOTB and custom reports.  We'll get no data, or SQL errors, or even 500 errors.  We estimate that we get an error on 33% of our efforts.


    More recently, reports have not been retrieving data.  We'll run a report on a program that has been active for a year, and we'll schedule that report only to receive no data.  This has been happening more and more each week.


    We've opened a few tickets with CA, but was wondering if other OD clients are having a similar experience.  We're planning to move to patch 7 as soon as we can get it tested, but I'm not seeing the resolution for our specific issues in the patch details.  In other words, we're shooting in the dark.



  • 2.  Re: Jaspersoft Instability Since Moving to 14.3

    Posted 06-28-2016 01:48 PM

    Hi Greg,

     

    There are multiple issues you have reported and cause can be of wide range. In 14.2 we changed the architecture to have a dedicated job server with a limit of 100 pages, so the load was getting distributed when you run reports immediately and scheduled.

     

    In 14.3 that change is yet to be and I believe we will have the same change done soon.

     

    On the data part if you are not running the load data ware house jobs and load data ware house rights job you will not get the data.

     

    Please share the case numbers we will work with you and ensure you don't face the issue.

     

    Regards

    Suman Pramanik



  • 3.  Re: Jaspersoft Instability Since Moving to 14.3

    Posted 06-30-2016 08:05 PM

    Hi GregHomrighous - We're you able to start working with Support on this? Thanks!