Layer7 Access Management

Expand all | Collapse all

CA Strong authentication-Invalid password format

Jump to Best Answer
  • 1.  CA Strong authentication-Invalid password format

    Posted 08-05-2016 02:23 AM


    Hi Team,

     

    I have integrated authminder 8.1 with CA siteminder 12.52. As you all know shim.fcc is the interface between these two products. I have CA directory as user store in siteminder. As im trying to authenticate a user over shim.fcc which is the auth scheme defined in siteminder i'm facing the below error in adaptershim.log in authminder and smps log in siteminder. The same authentication works with html form template and basic auth scheme. Can you please let me know why this happens Is it a problem with CA directory?

     

    Thu Aug 04 11:25:14.502 2016 NOTICE:  pid 4168 tid 5524: 0 Start SmAuthenticate for user [Bernd STARK]

    Thu Aug 04 11:25:14.502 2016 ERROR:   pid 4168 tid 5524: 0 [706051103]: Invalid password format

     

    Thanks

    Amith



  • 2.  Re: CA Strong authentication-Invalid password format

    Posted 08-08-2016 03:36 PM

    Hi Amit,

     

    Could you tell me what is the flow you are using and snippet of the active section from the adaptershim.ini file. We store the password in JSON format and there is a file name adapterintegration.js which comes in fcc folder and needed to placed in the virtual directory where you put the fcc files. Let me know the details.



  • 3.  Re: CA Strong authentication-Invalid password format
    Best Answer

    Posted 08-08-2016 04:04 PM

    Hi Namish,

     

    I somewhat fixed this. Initially I had localhost as my Web and app servers.

    Right now I have installed a domain controller and renamed localhost to a

    domain I created. This adapterintegration.js I guess was not found when

    using localhost in the tracer and a webagent error "500-17" was appearing.

    Also this is out of box functionality. We just need to create a virtual

    directory and rest will be taken care.  I'm still not sure why it dint work

    with localhost but now works with my self domain.

     

    All I now need is a free smtp service for otp please help me with that

     

    Thanks

    Amith

     

    On Aug 9, 2016 1:06 AM, "tiwna01" <communityadmin@communities-mail.ca.com>