Service Virtualization

Expand all | Collapse all

"The LISA VSE service could not match your request to recorded request"

Jump to Best Answer
  • 1.  "The LISA VSE service could not match your request to recorded request"

    Posted 09-15-2016 05:55 AM

    Hi Friends..

     

    Am using DevTestPortal -9 version..

    I am facing an issue,

    Steps:

    1) Application URL --https://virtualservice.com/calisa/communities
    2) Created virtual service and deployed in VSE --> (Note: IP and Port, 12.345.678.90:12345)
    3) The Xml is opening with <faultstring>The LISA VSE service could not match your request to recorded request</faultstring> when am pointing the URL https://12.345.678.90:12345/calisa/communities
    4) Verfied JVM and Config files

     

    Could you please help me..

     

    Thanks in advance...



  • 2.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 09-15-2016 07:42 AM

    This message "The LISA VSE service could not match your request to recorded request" usually means that your request transaction does not match any of the operation / signature entries in your VSI.  I would start by checking the request against the VSI.

     

    You can access Inspection View in the Portal and diagnose that way.  

    Or, go to the log file for your service and review the incoming request.  The log file will be in the lisatmp_ directory and begin with "VS_" followed by the name of your service.  You will see information including the operation and the arguments that DevTest parsed when the request arrived.  You can compare this information to the signature (Op & Args) in your VSI.  

     

    The entries in the VS_<yourVSName>.log look similar to this -- don't forget that CaSe SeNsiTiVity applies to args:

    2016-08-29 16:06:39,668Z (11:06)[Service_Name [VS_Service_Name_Run]/1] INFO  - Inbound Request {"id":0,"operation":"someOperationHere","arguments":{"incomingArg1":"W","incomingArg2":"1234AB","incomingArg3":"SU","incomingArg4":"ETC"}}

     

     



  • 3.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 09-15-2016 06:16 PM

    Maybe this document can help you using Inspection View when debugging transactions:

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1179674.aspx 



  • 4.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 09-26-2016 08:42 AM

    Hello Maria Heloisa Flores,

     

    Sorry for the late reply..

     

    Still am having confusions with this issue.

    I am using DevTest Portal -9 and am not able to get the solution from link which mentioned above.

     

    I have given real example with the message below,

    Scenario:

    Creating the virtual service from real service and getting the response from VSE for the same service.

     

    For Example;

    1) While capturing the transactions from the real service.
    Test Data:
    9.0
    2.0

    Request:
    <DevTest Portal>9.0</DevTest Portal>
    <DevTest Workstation>2.0</DevTest Workstation>

    Response:
    <DevTest Portal>9.0.Good One</DevTest Portal>
    <DevTest Workstation>2.0..It's going to retire</DevTest Workstation>

     

    2) When am trying to get response from VSE,

    Test Data:
    9.0
    2.0

    Request:
    <DevTest Portal>9.0</DevTest Portal>
    <DevTest Workstation>2.0</DevTest Workstation>

    Response:
    The LISA VSE service could not match your request to recorded request.

     

    Could you please answer for the below queries,

     

    1)where exactly the message "The LISA VSE service could not match your request to recorded request" will come??

     

    2) Why the message is coming??

     

    3) What are the possible ways to solve it.

     

    Thanks in advance.



  • 5.  Re: "The LISA VSE service could not match your request to recorded request"
    Best Answer

    Posted 09-27-2016 11:22 AM

    Trying to answer your questions below.  First though, you shared two request fields.  Can you share the full XML? There is no operation specified.  The VSI will match on a variety of things.  Operation is first and foremost followed by Match Style, then arguments in the argument list, then comparison values on the arguments. 

     

    1) Open your VSI and CLICK on the Service Image tab in the upper left.  Review the messages on the right.  This is likely one of the responses you are receiving.

    2) The message is coming because the service (VSI) could not match an incoming request to any of the transactions located under the Transaction tab next to the Service Image tab.  If the service looks exactly as you have described above, can you upload the VSI here?  

     

    3) Share with us a copy of what the incoming request looks like.  We need to see the operation and arguments that were parsed by the service when the request arrived for the specific request.  A copy of the exact request will exist in your VS_<yourServiceName>.log file located on your VSE in the lisatmp_*** directory where *** is usually the version number.

     

    To answer your question any more specifically, we need to see the VSI and the actual incoming request.  After we see these, we can provide a more direct answer as to why the request is not matching.



  • 6.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 09-27-2016 11:42 AM

    Thank you so much for the valuable and detailed response.

     

    Actually i couldn't able to share the request and response XML files since it's confidential one.

     

    Don't know what to do but want to know the solution..



  • 7.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 09-27-2016 12:12 PM

    See if you can get the data from your log for the virtual service or access the information via the Portal using the Inspection View for the service.  

     

    Examine the Inbound Request and compare the operation and arguments you see there to the operation and arguments coded in your VSI.  

     

    In the below picture, ONLY the FIRST request is valid.  

    The entries in red mismatch causing the 'LISA service could not match your request' response.  

    The second request mismatches because the operation is "" (empty).  That will not match the operation name in the VSI.  

    The third request errors because the request is missing the DevTest_Workstation argument and the VSI is expecting it.

    The fourth request errors because no arguments were parsed and the VSI is expecting two arguments.

    Also, be aware that cAsE sensitivity applies. 



  • 8.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 09-27-2016 12:34 PM

    Once again thank you much for this detailed answer.

     

    I will incorporate your comments to my scenario and let you know result.



  • 9.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 10-03-2016 10:31 AM

    Joel gave some great advice. You might find this documentation useful as well: Match Tolerance - DevTest Solutions - 9.5 - CA Technologies Documentation. It all comes down to match tolerance. Without seeing the data it is difficult to troubleshoot.



  • 10.  Re: "The LISA VSE service could not match your request to recorded request"

    Posted 10-05-2016 07:07 AM

    Be frank, You people are giving updates very effectively and quickly..Thank you so much