Symantec Access Management

Expand all | Collapse all

got error message during create domain or application

Jump to Best Answer
  • 1.  got error message during create domain or application

    Posted 02-22-2017 03:34 AM

    Hi,

    When I create domain or application in CA policy server admin UI

    I got the error message "Failed to execute CreateDomainEvent. ERROR MESSAGE: SmApiWrappedException:Class CA.SM::Domain does not have attribute CA.SM::Domain.IMSEnvironmentsLink"

    Did any one meet this kind of issue?

    Thanks.



  • 2.  Re: got error message during create domain or application
    Best Answer

    Posted 02-22-2017 04:17 AM

    Hi ,

     

    Do you have CA Identity Manager Integrated with Siteminder ?
    Did you imported IdmSmObjects.xdd ?

    Refer :

    CA Identity Manager Roles and Access Control - CA Single Sign-On - 12.6.01 - CA Technologies Documentation 

     

    Regards,

    Leo Joseph.



  • 3.  Re: got error message during create domain or application

    Posted 02-22-2017 04:47 AM

    Hi Leo,

    I need ask my colleague whether it is intergrated with CA Identity Manager.

    And is it mandatory to intergrate CA identity manager into CA SSO? (is the CA identity manager a seperate product which need order in seperate way?)or is there a walk-around way to solve it?

    Thanks.

    BRs//Teng Fei



  • 4.  Re: got error message during create domain or application

    Posted 02-22-2017 05:36 AM

    Hi BRs//Teng Fei,

     

    The error above can happen if:
    - Site Minder policy server was extended to support Identity Manager (running the IDM installer on the site minder machine)
    - The IdmSmObjects.xdd was not imported.

     

    Refer : Site Minder's WAM UI throwing "CA.SM::Domain.IMSEnvironmentsLink" error 

     

    Regards,

    Leo  Joseph.



  • 5.  Re: got error message during create domain or application

    Posted 02-22-2017 05:46 AM

    Hi Leo,

    Execuse me,

    was above two option both satisfied can lead the CA policy server works well?

    or like Just need IdmSmObject.xdd is enough?



  • 6.  Re: got error message during create domain or application

    Posted 02-22-2017 05:53 AM

    You shouldn't be needing to import IDM data dictionary file , if u are not going to utilise the integration.


    We may need to check this with IM team.

    Basically, what I think is there should be a way to diaable the IM integration.



  • 7.  Re: got error message during create domain or application

    Posted 02-22-2017 06:04 AM

    Hi Ujwol,

    Thanks for explanation, we are now finding a way to disable the IM integration , seems only to run the configuration wizard to reconfigure is the only way, right?

    Thanks.

    BRs//Teng Fei



  • 8.  Re: got error message during create domain or application

    Posted 02-22-2017 06:09 AM

    I am not too familiar with this integration. May be try uninstalling IDM extension if you installed it earlier on the Policy server machine?



  • 9.  Re: got error message during create domain or application

    Posted 02-23-2017 04:59 PM

    Hi ,

     

    How did you go with this ?

    Were you able to uninstall the IDM extension component or did you just import IdmSmObject.xdd file?



  • 10.  Re: got error message during create domain or application

    Posted 02-24-2017 12:46 AM

    Hi , feifrank

    I did get this exact error once but in my case it was the policy server.

    I suspect that you are neither able to create a new domain nor able to modify the existing one, with the error message Failed to execute CreateDomainEvent and Failed to execute ModifyDomainEvent.
    If that's the case,things i'll recommend before going too deep :-

     

    • List out the redundant Domains and remove them (as they may have issues)
    • Restart the Admin UI
    • Stop and start the policy server ,not restart it. (Make sure the service is stopped)

     

    Regards,
    Hridyesh



  • 11.  Re: got error message during create domain or application

    Posted 02-24-2017 12:51 AM

    Hi Hridyesh

    After my colleague reconfigured the system and import some file. it finally works! Thanks for answering my question. Now I solve it.

    THanks again to all!

    BRs//Teng Fei



  • 12.  RE: Re: got error message during create domain or application

    Posted 10-01-2019 03:22 AM
    May you Please, provide a bit more information what exactly you did , since i am getting this problem even after re-installing adminUI.
    The IdmSmObjects.xdd is also imported, still i am facing problem.


  • 13.  RE: Re: got error message during create domain or application

    Posted 10-02-2019 02:32 AM
    Hi all,

    You should note that in order to integrate IdM with SiteMinder, you
    need also to import specific data file into the Policy Store :

    To illustrate :

    If my installation on Linux, out of the box there are a set of Policy
    Store schema add :

    /opt/CA/IdentityManager/IAM_Suite/IdentityManager/tools/policystore-schema

    If the Policy Store is on CA Directory :

    On the CA Directory machine, copy the etrust_ims8.dxc. This file can be found
    in the where you have installed Identity Manager and the "Identity Manager Administrative Tools"

    ie: /opt/CA/IdentityManager/IAM_Suite/IdentityManager/tools/policystore-schema/eTrust/etrust_ims8.dxc

    # cp /root/download/etrust_ims8.dxc /opt/CA/Directory/dxserver/config/schema/

    # nano -w /opt/CA/Directory/dxserver/config/schema/axa.dxg

    # Identity Manager Schema
    source "etrust_ims8.dxc";

    and start the Policy Store. Now the Policy Server and AdminUI will show the
    Identity Manager data.

    I hope this helps,

    Best Regards,
    Patrick


  • 14.  RE: Re: got error message during create domain or application

    Posted 10-03-2019 06:08 AM
    Hii Patrick,
    Nice to hear from you, will you please let me know whether IM needs running , during Domain creation , actually our IM is integrated with siteminder but not running(up). Can it be the another reason of this problem ? or its ok even if IM is not up but it is siteminder integrated.


  • 15.  RE: Re: got error message during create domain or application

    Posted 10-04-2019 02:20 AM
    Hi Neetu,

    To apply the above steps, you don't need IdM to be up and running.

    I hope this helps,

    Best Regards,
    Patrick