Clarity PPM

Expand all | Collapse all

New Day - New Tool

  • 1.  New Day - New Tool

    Posted 10-12-2015 04:13 PM

    Hi all. New day - new tool to learn how to debug things in. Let's all learn together.

     

    In 14.3/Jasper 6 I created a small Ad Hoc view from the Time Management Domain:

    ad hoc view.jpg

     

    I successfully create and save a report from this view. When I navigate to the report to view it the following error is thrown:

     

    jasper_error.jpg

     

    I review the Jasper Logs - the same error is in this but there's no new information than the error shown.

     

    Where does one start to debug this?



  • 2.  Re: New Day - New Tool

    Posted 10-13-2015 02:22 AM

    Hi Rob,

     

    From the error it looks like the Load Dataware house job did not populate the fields. Can you run the job and see if it works.

     

    Regards

    Suman Pramanik



  • 3.  Re: New Day - New Tool

    Posted 10-13-2015 10:27 AM

    Hi Suman. Thanks for your response. What I've discovered is I think this is 100% Jaspersoft. I've reproduced this on both my Dev & Test systems as below

     

    1) Create a new Ad Hoc View from the Time Management domain.

    2) Add Resource Name & Resource Manager. Click OK.

    3) New Ad Hoc View will default to Crosstab. Add columns as below.

    crosstab.jpg

    Change layout to Table. Add columns and Group By as shown below.

    table.jpg

    View As Excel

    view_as_excel.jpg

     

    Field Not Found error will be thrown.

    field not found.jpg

     

    If, when building the Ad Hoc View I set the layout to Table first, before I add data, the error is not thrown.

     

    I started this thread to discuss how we'll debug stuff with Jaspersoft. (For Business Objects I went here: BOBJ Board). This one I simply googled and read the tea leaves. I found evidence of this error from Compiler issue with Crosstab and 'Group By' not being generated correctly and walked it back from there.

     

    Good news is the work around is to delete the view and build it in Table layout first. Bad news since the Ad Hoc View builder defaults to Crosstab so this isn't the last time I or probably my future users are gonna hit this.

     

    - Administratively, is there any way we can default this to Table?

     

    When initially pulling together data for a report I think returning the data in a table view is the way people are naturally used to thinking (excel, any query tool) to start. Grouping and visualizations come later. I think defaulting to Crosstab here is a poor design.