IT Process Automation

Expand all | Collapse all

Unable to open ITPAM console after login

Jump to Best Answer
  • 1.  Unable to open ITPAM console after login

    Posted 07-14-2016 02:43 AM

    Hi All,

     

    I am getting this error after login. Please help me in resolving this error.

     

    2016-07-14 07:03:02,909 ERROR [STDERR] [ Initialization] SLF4J: Class path contains multiple SLF4J bindings.

    2016-07-14 07:03:02,909 ERROR [STDERR] [ Initialization] SLF4J: Found binding in [vfszip:/C:/Program Files/CA/PAM/common/lib/slf4j-jboss-logging.jar/org/slf4j/impl/StaticLoggerBinder.class]

    2016-07-14 07:03:02,909 ERROR [STDERR] [ Initialization] SLF4J: Found binding in [vfszip:/C:/Program Files/CA/PAM/server/c2o/ext-lib/activemq-all-5.8.0.jar/org/slf4j/impl/StaticLoggerBinder.class]

    2016-07-14 07:03:02,909 ERROR [STDERR] [ Initialization] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.

    2016-07-14 07:03:02,909 ERROR [STDERR] [ Initialization] SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]

    2016-07-14 07:03:03,190 ERROR [com.optinuity.c2o.transport.TransportServer] [ Initialization] Exception starting server

    java.net.BindException: Address already in use: bind

    at sun.nio.ch.Net.bind0(Native Method)

    at sun.nio.ch.Net.bind(Net.java:444)

    at sun.nio.ch.Net.bind(Net.java:436)

    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)

    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)

    at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:187)

    at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:316)

    at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:265)

    at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)

    at org.eclipse.jetty.server.Server.doStart(Server.java:291)

    at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)

    at com.optinuity.c2o.transport.TransportServer.startServer(TransportServer.java:426)

    at com.optinuity.c2o.c2oserver.ServerManager.startTransportLayer(ServerManager.java:2021)

    at com.optinuity.c2o.c2oserver.ServerManager.boot(ServerManager.java:1205)

    at com.optinuity.c2o.c2oserver.ServerManager.initializeFullServer(ServerManager.java:544)

    at com.ca.pam.frontcontroller.ConfiguratorServlet$1.run(ConfiguratorServlet.java:40)

    2016-07-14 07:03:03,190 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [ Initialization] Exception occurred while booting up the Server

    com.optinuity.c2o.util.C2OException: Failed to start Transport Server - Could not start server

    at com.optinuity.c2o.util.ExceptionUtil.createException(ExceptionUtil.java:67)

    at com.optinuity.c2o.util.ExceptionUtil.createException(ExceptionUtil.java:60)

    at com.optinuity.c2o.c2oserver.ServerManager.startTransportLayer(ServerManager.java:2023)

    at com.optinuity.c2o.c2oserver.ServerManager.boot(ServerManager.java:1205)

    at com.optinuity.c2o.c2oserver.ServerManager.initializeFullServer(ServerManager.java:544)

    at com.ca.pam.frontcontroller.ConfiguratorServlet$1.run(ConfiguratorServlet.java:40)

    2016-07-14 07:03:03,190 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [ Initialization] Initialization of Server Manager Failed, will retry booting up -

    com.optinuity.c2o.util.C2OException: Error occured while booting up Server with an exception as : com.optinuity.c2o.util.C2OException: Failed to start Transport Server - Could not start server

    at com.optinuity.c2o.util.ExceptionUtil.createException(ExceptionUtil.java:67)

    at com.optinuity.c2o.util.ExceptionUtil.createException(ExceptionUtil.java:60)

    at com.optinuity.c2o.c2oserver.ServerManager.boot(ServerManager.java:1420)

    at com.optinuity.c2o.c2oserver.ServerManager.initializeFullServer(ServerManager.java:544)

    at com.ca.pam.frontcontroller.ConfiguratorServlet$1.run(ConfiguratorServlet.java:40)

     

     

    Thanks,

    Anitha



  • 2.  Re: Unable to open ITPAM console after login
    Best Answer

    Posted 07-14-2016 07:39 AM

    When you see an "Address already in use" message it is normally caused by a port already in use.  For example PAM would report:

     

    "Address already in use: host:8009"

     

    You could run netstat -a and work with your network team to find the port already in use and disable it so PAM could use it or rerun the install and change the port PAM uses to an open port.

     

    Your log is showing java.net.BindException: Address already in use: bind

     

    It is not showing which port is in use.  The "Address already in use: bind" is normally caused by port 80 being used.  By default IIS uses port 80.  Check to see if IIS is being used or started on this system.  Stop the W3SVC service and set the service to manual.  Reboot, confirm the W3SVC service is stopped and start PAM.

     

    Thank you!

     

    ~Scott Owens



  • 3.  Re: Unable to open ITPAM console after login

    Posted 07-14-2016 09:28 AM

    Thank you @SCOTT Owens . It Worked .