Layer7 API Management

Expand all | Collapse all

Incorrect mapping instructions error using the GMU

Jump to Best Answer
  • 1.  Incorrect mapping instructions error using the GMU

    Posted 08-30-2016 11:19 AM

    I am trying to migrate an OTK. But to my surprise I get the error "Incorrect mapping instructions: Cannot find entity type FOLDER with id: 0000000000000000ffffffffffffec76 in this entity bundle.. Mapping for: EntityHeader. Name=null, id=0000000000000000ffffffffffffec76, description=null, type = FOLDER"  while this mentioned folder is right there in the bundle (as the first item). The next two Folders in the 

     

     

    In the bundle it looks like this: 

    <l7:Item>
    <l7:Name>sap-accountmanagement</l7:Name>
    <l7:Id>b0cc674adb2a2ef13f2d555678a86e89</l7:Id>
    <l7:Type>FOLDER</l7:Type>
    <l7:TimeStamp>2016-08-30T12:14:47.191+02:00</l7:TimeStamp>
    <l7:Resource>
    <l7:Folder folderId="0000000000000000ffffffffffffec76" id="b0cc674adb2a2ef13f2d555678a86e89" version="2">
    <l7:Name>sap-accountmanagement</l7:Name>
    </l7:Folder>
    </l7:Resource>
    </l7:Item>

     

    and it is mapped as follows:

    <l7:Mapping action="NewOrUpdate" srcId="0000000000000000ffffffffffffec76" srcUri="https://10.249.123.241:8443/restman/1.0/folders/0000000000000000ffffffffffffec76" type="FOLDER"/>

     

    For the migrateOut I did not specify a defaulAction and the default mapping was:

    <l7:Mapping action="NewOrExisting" srcId="0000000000000000ffffffffffffec76" srcUri="https://10.249.123.241:8443/restman/1.0/folders/0000000000000000ffffffffffffec76" type="FOLDER">
    <l7:Properties>
    <l7:Property key="FailOnNew">
    <l7:BooleanValue>true</l7:BooleanValue>
    </l7:Property>
    </l7:Properties>
    </l7:Mapping>

     

    I ran manageMappings on all folders with --action NewOrUpdate, which in the end formed my bundle. Before rnuning that command I got the error that the migration failed, because the folder had to be created newly.

     

    Can someone explain why I get this enigmatic error?

     

    If necessary, I'll upload the files. But they would have to be cleared from sensitive information, so preferably not...



  • 2.  Re: Incorrect mapping instructions error using the GMU

    Posted 08-31-2016 01:02 PM

    HI Albert,

     

    Is there a reason you are migrating an OTK versus installing it on the target gateway using the solution kit?

    My recommendation would be to leverage the solution kit to install the OTK on the target gateway, then (possibly, if you really have to) use the GMU to migrate specific policy pieces that you want to the new installation.

    -GD



  • 3.  Re: Incorrect mapping instructions error using the GMU

    Posted 09-01-2016 02:54 AM

    I'm surprised that you ask: all the examples of the GMU use the OTK as an example... Apart from that, it seems the easiest way, as it - supposedly - saves a lot of manual configuration.



  • 4.  Re: Incorrect mapping instructions error using the GMU
    Best Answer

    Posted 09-01-2016 02:56 AM

    But actually I have solved the problem. What helped was defining a destination folder on the target gateway with the option: --destFolder.