Layer7 API Management

Expand all | Collapse all

Verifying ports opened: FAIL

  • 1.  Verifying ports opened: FAIL

    Posted 01-05-2017 05:42 PM

    I am reconfiguring API Portal to use new certificates and SSL.  I ran config_portal.sh and received an error: "Verifying ports opened: FAIL".  I looked in catalina.out, but see nothing useful.  What steps should I take next?



  • 2.  Re: Verifying ports opened: FAIL

    Posted 01-05-2017 05:51 PM

    Hi,

    Are the port currently in use? (#netstat -tnap | grep 80)

    I would recommend Manual method when sh config_portal.sh fails

    API Portal is ready to receive messages when the listen port 37080 is available:
    netstat -tnap
    You should see output similar to the following, with a list of the ports available:

    tcp 0 0 :::80 :::* LISTEN 28239/httpd  tcp 0 0 :::37080 :::* LISTEN 28541/java  tcp 0 0 :::443 :::* LISTEN 28239/httpd

     



  • 3.  Re: Verifying ports opened: FAIL

    Posted 01-05-2017 06:20 PM

    Hi Jeffery,

     

    1. Ensure that the keys that you have copied and pasted into the /opt/Deployments/lrs/server/conf/keys/  folder has the permission of 640 and ownership should be root:portalusers

     

    2. Look in the catalina.out if there are errors mentioned as follows

    Caused by: com.thelevel.repository.DocumentNotFound: DOCUMENT_NOT_FOUND

    Then follow this Techinical Solution

    Regards
    Seenu Mathew


  • 4.  Re: Verifying ports opened: FAIL

    Posted 01-06-2017 09:41 AM

    Hello,

     

    The script throws that error if the API Portal isn't listening on 443, 80, and 37080. You can run this command and should see the 3 lines of output like so:

     

    netstat -tnpl | grep "\(:80\|:37080\|:443\)"
    tcp        0      0 0.0.0.0:80                  0.0.0.0:*                   LISTEN      2792/httpd
    tcp        0      0 0.0.0.0:37080               0.0.0.0:*                   LISTEN      3317/java
    tcp        0      0 0.0.0.0:443                 0.0.0.0:*                   LISTEN      2792/httpd

     

    If all 3 of those ports aren't listening, then ensure that the following services are running:

    service apiportal status

    service httpd status

     

    If either of those services is stopped, start the service and try again.

     

    --Azad



  • 5.  Re: Verifying ports opened: FAIL

    Posted 01-09-2017 04:45 AM

    Hi Jeffery,

     

    Has any of the replies answered your question? Do you still have the error?

     

    Regards

    Seenu Mathew



  • 6.  Re: Verifying ports opened: FAIL

    Posted 01-09-2017 05:16 PM

    Thanks for the suggestions.  Sorry for the slow response, but I was out of the office for a couple days.  I tried all the suggestions, but I continue to get the same errors.  More information about the environment.  The environment that is not working has a single portal server and a single Gateway.  We are using SHA2 certificates.  I have tried to configure the portal to use only SSL, not HTTP.  When I open Portal using HTTPS, the browser tells me that the connection is insecure and it is using a certificate issued to localhost.localdomain.

     

    Our production and stage environments each have a single portal server and two gateway servers.  They are configured the same way, and work correctly.

     

    When I run netstat -tnpl | grep "\(:80\|:37080\|:443\)", I see

    tcp 0 0 0.0.0.0:37080 0.0.0.0:* LISTEN 29510/java
    tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 28463/httpd

     

    I thought the problem could be related to not seeing port 80.  However, stage environment, which is working correctly, does not show port 80.

     

    Do you have other ideas?



  • 7.  Re: Verifying ports opened: FAIL

    Posted 01-11-2017 03:47 AM

    Hi Jeffery,

     

    At this stage, I would suggest a new case be open with CA support. 

    Contact CA Support - CA Technologies 

    Please upload the catalina.log into the case.

     

    Regards

    Seenu Mathew