DX Infrastructure Manager

Expand all | Collapse all

Discovery Agent

Jump to Best Answer
  • 1.  Discovery Agent

    Posted 04-21-2016 11:40 AM

    Hello all,

     

    Hoping someone else has had the same issue here. I am using the discovery_agent in a separate VLAN to gather devices as well as have the ability to deploy the robot to systems. I have an issue where the remote hub that has the agent fails stating it cannot reach the discovery_server, but this is due to the fact that the hub in question does not have direct access to the discovery_server probe.. i.e. it has to travel between two hubs to reach the data_engine or discovery_server. Perhaps I am missing something that needs to be done for this to work? Documentation is a bit limited on this probe that I've found so I have yet to find a solution and with all of the OLD threads being imported into this forum its hard to sift there outdated info.

     

    Thanks in advance!

     

    Rick



  • 2.  Re: Discovery Agent
    Best Answer

    Posted 05-20-2016 10:21 AM

    Hi rick,


    So this usually comes down to a hub configuration / communication issue.

    When hubs are in different Vlan or network they are usually connected via  a tunnel.

    This allows all additional traffic to be routed over the tunnel port 48003 by default.

     

    If there is no tunnel set up then the application is expecting that all communication will be direct IE discovery_agent can talk directly to the discovery_Server on the primary on the port for the discovery_server.

     

     

    I would suggest that if you have not to setup a tunnel between the two hubs per the hub documentation.

    then to make sure you can not communicate on ports 48000-48002 in iether direction between the two hubs.

    If you have both direct and tunnel setup you will get unexpected results.

     

    once this is done I would test again.

     

    Also you can check your hub loglevel 3 logs for communication errors.

     

    one last thing I would make sure all hubs are on the same version.

    Below are recommended version best first

    7.80HF9 CA Unified Infrastructure Management Hotfix Index - CA Technologies

    7.72

    7.63

     

    hope this helps.



  • 3.  Re: Discovery Agent

    Posted 05-21-2016 12:57 AM

    Thanks Gene I actually do have a tunnel in place. I also tried 7.80HF9 but ran into a bug with that hub. For some reason, when doing the install on that hub somehow it stopped the hub, partially installed it then went offline. Basically, after looking at the hub folder it was missing all the daemons so the hub would never be able to start. It did this on three of the hubs, others worked fine. I'm still working on it but it's lower on my priority list currently. Thanks for the help and suggestions!



  • 4.  Re: Discovery Agent

    Posted 05-22-2016 10:19 PM

    I am using the discovery_agent in a separate VLAN to gather devices as well as have the ability to deploy the robot to systems.

     

    To the best of my knowledge discovery_agent has no connection to the robots.