DX Application Performance Management

Expand all | Collapse all

why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

Jump to Best Answer
  • 1.  why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-16-2016 05:15 PM

    Good afternoon,

    In the Workstation Investigator I search the SuperDomain for the metrics e.g. "Agent Connection Status" or regex (.*)Agents(.*):Metric Count and I get at the bottom of the window: "128 matches found". However, when I export the data of the 128 highlighted lines the csv only contains 101 lines (it worked as-is in v8, but not v9.5 :-)

     

    Where is the property to set the export to more than 100 lines?

    Thanks,

    Fred



  • 2.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-17-2016 04:22 PM

    Hi Fred,

     

    I tested this in 10.0 and was able to get more than 100 lines.  What version are you using?

     

    thanks,
    Matt



  • 3.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-17-2016 05:45 PM

    Hi Matt,

    I am using 10.1 for my testing.

    I used various time ranges with the resolution greater than the range as to get only one data point e.g. range 8 min and resolution 12min. and when I export I get 100 agent lines. I also did a clw and matches the gui.

    "get historical data from agents matching \".*\" and metrics matching \".*Metric Count\" for past 1 minute with frequency of 120 secs" | awk -F ',' '/Agents/ {print $5}' | sort -u | wc -l

    129

    Tell me something: in your test, does the line count in your exported csv match your agent count ?

    Regards,

    Fred



  • 4.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?
    Best Answer

    Posted 06-20-2016 12:33 AM

    Hi Fred,

    I tested this in 10.2.

    With my search tests I get >100 matches.

    When I select all I see "Data limited to 100 matching metrics" in graph pane which is expected behaviour.

    With 8 mins/15 seconds "Export Data" is not limited.

    With 8 mins/12 mins my "Export Data" is always limited to 101 rows similar to you

    I will do some more digging.

     

    Regards,

     

    Lynn



  • 5.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-20-2016 04:55 AM

    " for past 1 minute with frequency of 120 secs" does not make much sense to me!



  • 6.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-20-2016 08:58 AM

    I agree, but how do export only one line per agent ?

    (I was getting  2 data points for the "for past 1 minute with frequency of 60 secs" so the 120 sec was an attempt to do a get one data point)



  • 7.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-20-2016 04:35 PM

    I had the graph closed to avoid the refresh delays, but it does indeed show in red the limit to 100.

    Are you sure that in your first test you have more that 100 metrics * (8 * 60 / 15) = 3200 data points?

     

    CA Support told me of a (the) solution on the MoM introscope.enterprisemanager.workstation.viewerMetricLimit=<nbr> , but I surmise that this is not a good idea to increase to a much larger number as it affects every graph and user.



  • 8.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-20-2016 08:54 AM

    Hi Fred:

        I see that Lynn is looking into this. But it seems to me that this is a good candidate for a case with an Engineer looking at your screen and environment. That conversation/review should review the cause of the behavior that you are seeing

     

    Thanks

    Hal German



  • 9.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-20-2016 10:10 AM

    Hi,

    Lynn nailed it and looking into it.

    I was hoping to have a very simple GUI way, for non-Admins, to export all agents (and some useful metric)  to some Excel with only one line per agent.

    In later releases we have some scripts, but the GUI way was supposed to be more versatile and less talking:-)

    Regards,

    Fred



  • 10.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-21-2016 06:35 AM

    Lynn has replicated the behavior so I am marking as answered. I know that Fred and Lynn are both researching this and will report back what they find.



  • 11.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 06-24-2016 09:26 AM

    I was thinkink about adding an idea to have a checkbox next to regex to enable a "Show All Metrics", but then I thought that this needs to be done in Webview.

    Now trying to think how this should work in Webview is a much longer exercise as there other basic navigational challenges to fix first. Also there might be cleverer ways to integrate Excel with maybe using the rest interface.

    Furthermore I'd want to have first better event logging on the MoM so that when folks crash it I know who and why



  • 12.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 01-08-2017 11:20 PM

    Hi Fred,

    I recently worked another case where customer was being export data limited to 100 metrics from the GUI due to the data viewer property introscope.enterprisemanager.workstation.viewerMetricLimit limit (default 100). However after I suggested they test with CLW it did give them all the required data which I think we would expect because the property should only impact the data viewers in the Workstation GUI.

    However looking back at this thread I see you also tested with CLW and it still seemed to be limited by the 

    https://communities.ca.com/thread/241756061#comment-241892975 

    Is that correct?

     

    Thanks

     

    Lynn



  • 13.  Re: why doesn't "Workstation Investigator > Viewer > Export Data" show everything?

    Posted 01-02-2017 11:32 AM

    Thanks Fred for the update.. Let us know if you find a good workaround at a later date.