DX Application Performance Management

Expand all | Collapse all

Configure JBoss EAP in Domain mode to use Java agent

Jump to Best Answer
  • 1.  Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 12:53 PM

    Hi, we are trying to configure JBoss EAP in Domain mode to use Java agent in two servers, but we have some problems...

     

    Java Agent release is 9.7

    One server has the JBoss EAP 6.3.3 and Red Hat Enterprise Linux Server release 7.2 (Maipo) master

     The second has JBoss EAP 6.3.3 and Red Hat Enterprise Linux Server release 6.6 (Santiago) esclavo

     

    The log console show the following:

     

    [Server:sma3]  [31m [0m [31m09:07:23,862 ERROR [org.jboss.as.server] (ServerService Thread Pool -- 103) JBAS015870: La implementación de "WebAppSupport.jar" se deshizo con el siguiente mensaje de fallo:  [0m
    [Server:sma3]  [31m{"JBAS014671: Servicios fallidos" => {"jboss.deployment.unit.\"WebAppSupport.jar\".INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"WebAppSupport.jar\".INSTALL: JBAS018733: Error al procesar la fase INSTALL de deployment \"WebAppSupport.jar\" [0m
    [Server:sma3]  [31m Caused by: java.lang.NoClassDefFoundError: com/wily/introscope/agent/AgentNotAvailableException [0m
    [Server:sma3]  [31m Caused by: java.lang.ClassNotFoundException: com.wily.introscope.agent.AgentNotAvailableException"}} [0m
    [Server:sma3]  [31m [0m [0m09:07:23,877 INFO [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015877: Se detuvo la implementaciónWebAppSupport.jar (runtime-name: WebAppSupport.jar) en 15ms [0m
    [Server:sma3]  [0m [0m09:07:23,879 INFO [org.jboss.as.controller] (ServerService Thread Pool -- 103) JBAS014774: Reporte del estatus del servicio [0m
    [Server:sma3] JBAS014777: Servicios que no lograron iniciar: service jboss.deployment.unit."WebAppSupport.jar".INSTALL

     

    We believe that the problem is the location of the file "WebAppSupport.jar", where this file should be place ? what path ? in this moment the path of the file is <Agent_Home>/core/ext. The path of the file "IntroscopeAgent.profile" is <Agent_Home>/core/config.

    Where we find a clear configuration instructions to configure JBoss EAP in Domain mode to use Java agent ?, what others things may be causing the problem?

     

    Thank  a lot !



  • 2.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 01:27 PM

    Hello Eduarte,

     

    Please have a look under our Knowledge Base:

     

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec606413.aspx?intcmp=searchresult… 

     

    In Services,

    Gustavo.



  • 3.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 02:44 PM

    Hi Gustavo, thank you, we have JBoss EAP 6.3.3 and the knowlege base that you refer is about JBoss 7 AS, this information applies to our case ?

     

    Thank you!



  • 4.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 03:06 PM

    Hi 

     

    Did the KD that I point to help?

     

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/TEC1230085.aspx

     

    It is on EAP 6.1.1 but may apply as well to EAP 6.3.3.



  • 5.  Re: Configure JBoss EAP in Domain mode to use Java agent
    Best Answer

    Posted 09-14-2016 02:41 PM


  • 6.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-15-2016 10:21 AM

    Hi Hallett, thanks a lot for you help, we follow the instructions in KD and it works properly.

     

    Thanks!



  • 7.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 02:44 PM

    Hi Elbert:

     

    Please review as soon both knowledge docs and let us know if they were helpful or if you need additional assistance

     

    Thanks

    Hal German



  • 8.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 03:32 PM

    Hi Hallett, thank you for the information, we review it and after that I reply to you if it was helpful.

     

    Thanks



  • 9.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 03:50 PM

    Hi Hallett, one question more, we have a domain server with three (3) slave servers, all agent configuration is only in the domain server or in slave servers are required to set something ?

     

    Thanks a lot.



  • 10.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-14-2016 04:57 PM

    Hi:

    Reading that KD it sounds like the domain server  populates it to the slave agents. Asking the creator of that knowledge Doc SergioMorales to respond further on this thread

     

    Thanks

    Hal German



  • 11.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-15-2016 09:20 AM

    Hi:

    Marking as answered since one of the two KDs should take care of the issue and it may take you some time to review/test. After completing that, please let us know the results

     

    Thanks

    Hal German



  • 12.  Re: Configure JBoss EAP in Domain mode to use Java agent

    Posted 09-15-2016 02:11 PM

    Thanks. for the update. Good to hear that the slave agents worked