DX Infrastructure Manager

Expand all | Collapse all

rsp probe not connecting to some Linux 2.6 systems

  • 1.  rsp probe not connecting to some Linux 2.6 systems

    Posted 07-01-2015 01:49 AM

    Hi,

    I have issue with rsp probe connecting to some of systems( Avaya CM). I am able to connect through ssh tools but not with rsp probe , I tired mulitple versions of RSP but did'nt work. I help on same..

     

    ***

     

    Jul  1 11:12:07:797 [7816] rsp: thrDiscoverHost: Discovering OS

    Jul  1 11:12:07:797 [7816] rsp: connect_ssh: do ssh_connect for host 192.168.xx.xx

    Jul  1 11:12:07:920 [7816] rsp: authenticate: try to authenticate

    Jul  1 11:12:07:927 [7816] rsp: authenticate: authenticate methods: 20

    This system is restricted solely to authorized users for legitimate business    

    purposes only. The actual or attempted unauthorized access, use or modifications

    of this system is strictly prohibited. Unauthorized users are subject to 

    company disciplinary procedures and or criminal and civil penalties under state,

    federal or other applicable domestic and foreign laws.

    The use of this system may be monitored and recorded for administrative and 

    security reasons. Anyone accessing this system expressly consents to such 

    monitoring and recording, and is advised that if it reveals possible evidence 

    of criminal activity, the evidence of such activity may be provided to law 

    enforcement officials.

    All users must comply with all corporate instructions regarding the protection 

    of information assets.

    Jul  1 11:12:07:927 [7816] rsp: Authentication failed for host 192.168.xx.xx

    Jul  1 11:12:07:927 [7816] rsp: thrDiscoverHost: Connection attempt with 192.168.xx.xx failed.

    Jul  1 11:12:07:927 [7816] rsp:  Time taken in discovering 192.168.xx.xx=5

    Jul  1 11:12:07:927 [7816] rsp: SREPLY: status = 3(invalid argument) ->192.168.xx.yy(HUB)/58354

    Jul  1 11:12:07:927 [7816] rsp: do_disconnect: starting disconnect

    Jul  1 11:12:07:927 [7816] rsp: do_disconnect: no connection

    Jul  1 11:12:07:927 [7816] rsp: CleanDatabaseObject: Closing the local db connection

    Jul  1 11:12:07:927 [7816] rsp: FreeConnection: Connection released

    Jul  1 11:12:08:040 [7900] rsp: GetDatabaseObject: ECS

    Jul  1 11:12:08:040 [7900] rsp: insert_into_database: Time taken bteween transaction start and Job queue pop finished=0,0.000000



  • 2.  Re: rsp probe not connecting to some Linux 2.6 systems

    Posted 07-01-2015 02:25 AM

    I also observe for systems where login is not happening log reads "rsp: authenticate: authenticate methods: 20" and for others "rsp: authenticate: authenticate methods: 6".

    ***** Log for other Linux

    Jul  1 11:52:22:839 [7368] rsp: connect_ssh: do ssh_connect for host 192.168.xx.zz

    Jul  1 11:52:22:898 [7368] rsp: authenticate: try to authenticate

    Jul  1 11:52:22:948 [7368] rsp: authenticate: authenticate methods: 6

    Jul  1 11:52:22:948 [7368] rsp: authenticate: trying to authenticate with auth passwd

     

    Any reason why?



  • 3.  Re: rsp probe not connecting to some Linux 2.6 systems

    Posted 07-07-2015 02:16 AM

    Hi

    I can see upto rsp 2.92 can connect to given system. Is rsp probe stopped using plink as now log shows  ssh_connect?



  • 4.  Re: rsp probe not connecting to some Linux 2.6 systems

    Posted 07-07-2015 03:08 AM

    Hello.

    I'm not sure if it helps. Just for your information.

     

    I have seen similar symptom with Solaris platform. The older version of RSP is able to interact with the platform while newer version of RSP is NOT.

    It was resolved by having your SSH modules up-to-date. (via OS service packs).

    It may not resolve your issue, but just for your information.

     

    Thanks

    Yu Ishitani



  • 5.  Re: rsp probe not connecting to some Linux 2.6 systems

    Posted 07-07-2015 07:17 AM

    I believe plink is used by rsp only on windows

     

    -jon



  • 6.  Re: rsp probe not connecting to some Linux 2.6 systems

    Posted 07-08-2015 12:34 AM

    Correct plink used in Windows , but I feel CONNECT method has been changed in RSP probe (Unix/Windows robot) after 2.92 which does not allow Linux systems configured in high security mode for interactive login only.

     

    Any comment from Dev team?

     

    -Mohi