Clarity PPM

Expand all | Collapse all

14.2 Upgrade Error

Jump to Best Answer
  • 1.  14.2 Upgrade Error

    Posted 07-01-2015 06:46 AM
      |   view attached

    Hi all,

     

    I am upgrading our Dev environment to version 14.2 from the 13.1 version.

     

    I completed all of the recommended pre-upgrade activities, upgraded my Java to 1.7.0_67 and set the correct PATH. I also upgraded my Tomact version to apache-tomcat-7.0.55

     

    The pre-install check highlighted a few warnings but nothing which I had not seen when I upgraded our Sandbox to 14-2.

     

    So I proceeded with the installation.

     

    After about ten minutes the install fails with the following:

     

    BUILD FAILED

    D:\niku\temp\v14-2\gateway.xml:34: The following error occurred while executing

    this line:

    D:\niku\temp\v14-2\install.xml:259: The following error occurred while executing

    this line:

    D:\niku\temp\v14-2\install.xml:439: The following error occurred while executing

    this line:

    D:\niku\temp\v14-2\install.xml:483: No message

     

    When I check the install.log file I see:

     

    7/01/15 6:29 AM (Echo) D:\niku\temp\v14-2\install-packages\13.2.0\upgrade-repack.13.2.0.472tpexcludes\install.xml:258: Fatal error occurred while trying to process d:\niku\clarity_prev or d:\niku\clarity

    7/01/15 6:29 AM (Echo)

    7/01/15 6:29 AM (Echo) Total time: 10 minutes 11 seconds

    7/01/15 6:29 AM (UnknownElement) Task "fail" finished with error.

    D:\niku\temp\v14-2\install.xml:873: The upgrade step for 13.2.0 failed. Please consult the

                     D:\niku\temp\v14-2\install-packages\13.2.0\upgrade-repack.13.2.0.472tpexcludes/install.log for that release package."

     

    The install.log file is attached.

    I am currently restoring my db and application backups.

     

    Can anyone please suggest a reason for this upgrade failure and how I can avoid it in my next attempt?

    Thanks!

    Attachment(s)

    zip
    install.log.zip   4K 1 version


  • 2.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 06:59 AM

    Hi Collin,

     

    Just saw the install log and it looks like the permission issue you are hitting and the upgrade is breaking.

     

    7/01/15 6:29 AM (UnknownElement) Task "move" finished with error.

    D:\niku\temp\v14-2\install-packages\13.2.0\upgrade-repack.13.2.0.472tpexcludes\install.xml:250: Unable to delete directory d:\niku\clarity\webroot\Custom_Html

      at org.apache.tools.ant.taskdefs.Move.deleteDir(Move.java:322)

      at org.apache.tools.ant.taskdefs.Move.deleteDir(Move.java:293)

      at org.apache.tools.ant.taskdefs.Move.deleteDir(Move.java:311)

     

    Can you please check if you have the required rights.

     

    Regards

    Suman Pramanik



  • 3.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 07:06 AM

    I see.

     

    I think I may have to remove the Custom_Html folder or at least get rights to do so!

    I'll also get rid of any other folders which may interfere with the upgrade process.

     

    Thanks guys!



  • 4.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 07:11 AM

    I also checked the Cust_Html folder properties and it is a shared folder - possibly why it could not be deleted?

     

    I have removed it from the webroot folder and backed it up on another location.

     

    Once I have restored by backups to previous config I'll reattempt the 14-2 upgrade and let you know how it goes.



  • 5.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 07:46 AM

    Ok this time the upgrade fails with messages about invalid NSQL queries and duplicate time slice requests in the post-check.html file

     

    We're going to see if we can get these corrected.



  • 6.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 08:12 AM

    Invalid SQL shouldn't fail. would love to see the new install log

     

    Regards

    Suman



  • 7.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 08:16 AM

    yes I was just comparing the install.log file from my successfull Sandbox upgrade and my failed Development upgrade attempt. In the Sandbox the same invalid NSQL messages appeared but the upgrade completed successfully.

     

    I have sent you the latest install.log file



  • 8.  Re: 14.2 Upgrade Error
    Best Answer

    Posted 07-01-2015 08:19 AM

    Hi Colin,

     

    You are hitting a bug

     

    7/01/15 6:15 AM (SQLTask) java.lang.NullPointerException

    7/01/15 6:15 AM (SQLTask)          at com.niku.tools.taskdefs.JDBCSecurePasswordTask.getConnection(JDBCSecurePasswordTask.java:44)

     

    This is due to a known bug CLRT-77615 and the workaround is below

     

    Go back to the CSA properties > security tab before upgrade, under the Encrypt Passwords section change the setting (e.g. from No Encryption to Using System Key), click on Save, change the setting back again (e.g. from Using System Key to No Encryption), click Save again. Now the <encryption> element will exist and the useSystemKey attribute should exist too. Now the upgrade should proceed without error.

     

    Regards

    Suman Pramanik



  • 9.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 08:22 AM

    Thank you so much for your fast response. I am currently restoring my pre-upgrade attempt db and app backup files.

    Once these are in place I will ensure to apply the settings above before reattempting upgrade.

     

    I'll let you know how this goes.



  • 10.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 08:28 AM

    I look forward to hear from you.

     

    Regards

    Suman Pramanik



  • 11.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 09:17 AM

    Hi Collin,

     

    Also i see the below error

     

    7/01/15 6:15 AM (Echo) Database Vendor = mssql

    7/01/15 6:15 AM (Echo) Current Database Version = 10.50.2500.0 - DEVELOPER EDITION (64-BIT)

     

    MSSQL Developer edition is not supported and only below are supported

     

    ■ Microsoft SQL Server 2008 R2 Enterprise Edition: Any service pack5c)

    ■ Microsoft SQL Server 2012 Enterprise Edition: Any service pack

     

    Apart from it please ensure app and database timezone are same.

     

    Regards

    Suman Pramanik



  • 12.  Re: 14.2 Upgrade Error

    Posted 07-02-2015 06:02 AM

    Hi Suman,

     

    the workaround for the known bug re: Encrypt Password did the trick.

    Once I applied the steps you advised in the NSA the upgrade ran successfully.

     

    One other question - the upgrade took over 7 hours to complete. We ensured to apply all the pre-upgrade recommendations by CA before we began. Is this normal time for a 14-2 upgrade?



  • 13.  Re: 14.2 Upgrade Error

    Posted 07-02-2015 12:42 PM

    The upgrade time can vary due to infrastructure, volume of data. So yes I have seen upgrade taking 7 hours or more

     

    Regards

    Suman Pramanik



  • 14.  Re: 14.2 Upgrade Error

    Posted 05-30-2017 07:17 AM

    Hi Suman,

     

    Was it an issue with only v13.1? Because recently I was trying to upgrade from 15.1 to 15.2 and I also got the same error in install logs. I followed the steps you have provided and it worked. I was a bit surprised to see that the bug still exists, and that too in v15.1 

    Am I the only one who faced this issue while moving from 15.1 to 15.2? Or is there a chance CA has provided any fix for this that I am missing on?

    Will be glad to hear any update on this.

     

    Regards,

    Pratipurna



  • 15.  Re: 14.2 Upgrade Error

    Posted 07-01-2015 06:59 AM

    Well your errors seem to start with a "Unable to delete directory" message ; could be permissions / operating system locks related?

     

    ( some previous threads on here with that error indicated manually removing thongs might help ).