DX Infrastructure Manager

Expand all | Collapse all

Data_Engine queue not draining

  • 1.  Data_Engine queue not draining

    Posted 09-21-2015 02:38 AM

    Hi All,


    This is regarding Data_Engine queue, which is not draining and have stopped working. we have tried to restart and deactivate/activate data_engine, however did't work.

    we have checked logs of data_engine and found one event "QoSInsert::Reconnect_BulkInsert - threads stopped after 77 ms", does it have any significance on this issue or what might be the possible solutions for this issue.



  • 2.  Re: Data_Engine queue not draining

    Posted 09-21-2015 04:07 AM

    Hi,

     

    I'd expect to get a lot more information from the data_engine log. I suggest turning up the loglevel to 3 or 5 if you haven't done so already. In my experience there's pretty much always a reason there why it's not working, if it's got something to do with data_engine or data structure. You should also do some basic DB healthcheck stuff, such as disk space for log / db files, file size restrictions for data files, etc if it can't insert anything at all. If it's just being very slow (can seem like it's stopped altogether), then disk statistics are a good place to look at as well, especially queue sizes.

     

    -jon



  • 3.  Re: Data_Engine queue not draining

    Posted 09-24-2015 04:40 AM

    Hi Jonhcw,

    Thanks for reply, however we had already checked DB space and it was fine.

    We found that QOS_data got stuck as some of the table did not have setting of auto grow in DB and it was not storing data.

    We have asked DB team to make it auto grow and remove restriction of data storing, it worked and issue has been resolved.