Layer7 Access Management

Expand all | Collapse all

smldapsetup not responding

  • 1.  smldapsetup not responding

    Posted 03-15-2015 08:31 AM

    Hi All,

     

    I have installed siteminder policy server version 12.51.3 on RHEL server, Installation was pretty normal and successful.

     

    I tried to configure policy store setup using smldapsetup reg command. But the command is not responding.

     

    smldapsetup reg -hldapserver.mycompany.com -d”LDAP User” -wMyPassword123 -ro=security.com

     

    Not registered in sm.registry file.

     

    Did anyone face this issue before ?

     

    Can I directly edit the s.registry file to setup policy store and keystore ? How can I do that ?

    Right now I donot have smconsole - Policy Server management console (Xwindow problem) that's why I tried smldapsetup to configure. But it failed.

     

    Thank you

     

    Regards

    Saravanan



  • 2.  Re: smldapsetup not responding

    Posted 03-16-2015 02:44 PM

    Saravanan Nalla

     

    I think it is the rootDN which may be causing the issue here.

     

    You need to provide the complete DN in this format <o=security,c=com>

     

    smldapsetup reg -h127.0.0.1 -p1111 -d"cn=Directory Manager" -wMyPassword123 -ro=security,c=com

    or

    smldapsetup reg -h127.0.0.1 -p1111 -d"cn=Directory Manager" -wMyPassword123 -rdc=security,dc=com



    If it does not resolve, please suggest the below

    • Version / Type of Policy Store.
    • Is SSL enabled
    • Is there any intermediate component e.g. Directory Proxy etc.



    Let know if this helps!


    Regards


    Hubert



  • 3.  Re: smldapsetup not responding

    Posted 03-16-2015 04:35 PM

    that ending "-ro=security.com" looks funny, please double  check your server.

     

    have you tried to trace this?

     

    yes it is possible to  edit the sm.registry file, but better to  adjust the  smconsole instead.