Layer7 Access Management

Expand all | Collapse all

Smtest tool does not work with 12.51 SDK

  • 1.  Smtest tool does not work with 12.51 SDK

    Posted 03-19-2015 11:54 AM

    Problem:

    After installing the smtest tool in sdk version 12.52SP1 with working hco and agent/shared secret combinations getting the following in the smps.log

     

    [LogMessage:ERROR:[sm-Server-01070] Failed handshake with ***.***.***.***:yyyy]

     

    Was working with previous version of SM test tool

     

    Solution:

    You should check that you do not have multiple version of ETPKI packages installed on your box and install the one provided with the SDK.

     

    Check the following registry for installed libraries:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\Shared\CAPKI\Dependencies



  • 2.  Re: Smtest tool does not work with 12.51 SDK

    Posted 03-19-2015 12:02 PM

    what operating  system?

     

    Pete B and Nate W can attest to some... hiccups... with R12.52 and R12.52 SP1 ....



  • 3.  Re: Smtest tool does not work with 12.51 SDK

    Posted 03-20-2015 11:41 AM

    OS Is Windows 2008 R2 and problem encountered was because of a confict with another CA product installed that conflict with ETPKI packages Installed.



  • 4.  Re: Smtest tool does not work with 12.51 SDK

    Posted 03-20-2015 11:44 AM

    interesting. i had issues on 2008 r2 due to lack of ETPKI being installed by the sdk... used R12.52 and then R12.52 SP1 installers.

     

    that lead to this thread:

    SiteMinder Test Tool and Policy Server R12.52 SP0 CR1 Build154