Clarity Service Management

Expand all | Collapse all

grloader and excel formating

Jump to Best Answer
  • 1.  grloader and excel formating

    Posted 02-04-2015 06:24 AM

    Hi team,

    OK, this is possibly more excel than grloader question, but I assume someone must have similar experiences

     

    I have Excel (.xlsx) document with some CI's information. One attribute column consists of mixed string and long numbers and it should be stored as string in CMDB. Though I formated the whole column as Text in Excel, grloader still stores all the "numbers" as 2147483647 which is the longest possible integer.

     

    Any ideas?

     

    Thanks a lot,

    Jakub



  • 2.  Re: grloader and excel formating

    Posted 02-04-2015 07:15 PM

    Hi Jakub,

     

    Whats the name of the field which you are trying to import string and long number?

     

    Thanks,

    Naveen



  • 3.  Re: grloader and excel formating

    Posted 02-05-2015 06:02 AM

    Hi Naveen,

    it's custom field on nr object (z_evn STRING 255).

     

    Jakub



  • 4.  Re: grloader and excel formating
    Best Answer

    Posted 02-05-2015 08:23 AM

    Just copy and paste the whole data into a new sheet (with values only option) to clear up whole formatting. Excel can mysterious when it comes to data formatting.

     

    Personally I usually go with CSV instead, you may try that as well if it's convenient.



  • 5.  Re: grloader and excel formating

    Posted 02-05-2015 08:01 PM

    Hi,

    there must be a kind of black magic involved in Excel formating - the trick to copy the sheet with values only option didn't work.


    The idea of using csv files instead of XLS works perfectly without any issues - thanks for the tip.

     

    Regards,

    Jakub