DX Infrastructure Manager

Expand all | Collapse all

Dynamic Dashboards are not built/published in UMP

  • 1.  Dynamic Dashboards are not built/published in UMP

    Posted 08-03-2011 03:16 AM

    I am finding that dynamic dashboards for some "interface_traffic" probes are not being built/published to UMP in "dynamic views".

     

    The data is available in SLM and the dashboards are available in the Nimsoft Server page, but not in UMP. The relevant data can be added to a custom dashboard.

     

    Manually running the SQL query shown in the group_server configuration returns the the correct results.

     

    This issue also existed before upgrading to the latest version of UMP. 

     

    I have tried ctrl-p/reset on teh group server probe.

     

    Nimsoft Server 5.11

    UMP 2.51 (wasp 2.91, group_server 2.65)



  • 2.  Re: Dynamic Dashboards are not built/published in UMP

    Posted 08-03-2011 05:34 PM
    I believe the default grouping behavior for NMS 5.11 and UMP 2.51 changes and doesn't really use the old group_server probe tables. It may be using the newer nis_server tables instead.

    You can force it to use the old group_server method if you edit the dashboard_engine using raw config (shift+ R Click), "data" folder, and set use_nis_server = 0. to see if that changes anything for you.


  • 3.  Re: Dynamic Dashboards are not built/published in UMP

    Posted 08-04-2011 02:00 AM

    Thanks jlopez.

     

    I tried this and got a different  type of strange behaviour: The interface_traffic dynamic dashboards are now present and working correctly but all of the Windows dyamnic_dashboards just show the template. Strange - I have changed back to using NIS server and the behaviour is as before.

     

     



  • 4.  Re: Dynamic Dashboards are not built/published in UMP

    Posted 08-04-2011 07:32 AM

    Did you try the rebuild button when viewing the servers? I am not sure if that will help, but it might.



  • 5.  Re: Dynamic Dashboards are not built/published in UMP

    Posted 08-04-2011 03:45 PM
    I did the same and the dashboard updated with data after I rebult them.


  • 6.  Re: Dynamic Dashboards are not built/published in UMP

    Posted 08-15-2011 02:25 AM

    When using the group_server rather than the NIS server, clicking the rebuild button has some effect:

     

    - On all Windows servers I can see the status table and the links to alarms are active and accurate.

    - On a couple of servers the performance summary meters are shown.

     

    Overall this doesn't yield much success though. I have cleared browser cache, waited > 1 hour and logged in as multiple users and the result is that same.



  • 7.  Re: Dynamic Dashboards are not built/published in UMP

    Posted 08-04-2011 09:44 PM

    Interesting your interfaces showed up again.  

     

    I'm having similar dynamic dashboard build issues when using nis_server table.  I came across this dash_eng setting from support when I submitted a ticket b/c system dashboards break/incomplete for systems running cluster probe.  This was also for UMP 2.1.2 not just 2.5.    The cluster VIP seems to get loaded into the nis table as source for attached SAN drives per SQL resource along with all the host cdm info (source by hostname) but when dashboard generates it pulls only the VIP info so I can't see the main cdm information (cpu,mem, etc.) metrics. Only the SAN disks associated to the cluster VIP show up in the disk list section  Turning this use nis off I get the dashboards working once again as they did in 1.5.1. 

     

     



  • 8.  Re: Dynamic Dashboards are not built/published in UMP

    Posted 08-17-2011 12:14 PM

    Did anybody succeed in showing dashboard for both cdm/rsp servers?

    I am using UMP2.5.1+NMS5.1.1 (cdm4.54, rsp2.68, dash_eng3.30) environment then no server in Dynamic Views.

     

    Is there any trigger for server to appear in the tree?? I checked all QoS publish boxes but things were not changed.

    Please advise if I should open a case for this...

     

    Thanks!!

    Miki