DX Infrastructure Manager

Expand all | Collapse all

Status on Nimsoft Monitor 7.5 release

Anon Anon05-12-2014 03:45 PM

Anon Anon05-12-2014 07:39 PM

  • 1.  Status on Nimsoft Monitor 7.5 release

    Posted 05-06-2014 03:28 PM

    Figured it was time to do a thread on it's own when it comes to the 7.5
    release of Nimsoft Monitor.

     

    How many people have upgraded to NMS 7.5? What kind of environments are
    you using it in? Using tunnels? And so on.

     

    What problems have you run into and/or are currently experiencing with 7.5?

     

    Hopefully we can gather some community feedback when it comes to 7.5,
    that perhaps will carry some weight.



  • 2.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-06-2014 03:29 PM

    We're currently only using 7.5 in our lab environment with ~4 extra
    hubs (in addition to primary hub). And tunnels between them. The
    evironment has about 50 test robots.

     

    After downgrading the robots to 7.05, the tunnels appear more stable,
    but we are currently seeing large amounts of "communication errors"
    when doing package management, deploying probes and/or configuring

    probes.

     

    Also, rumour has it the nas that comes with 7.5 has some problems.



  • 3.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-06-2014 07:04 PM

    I'm also experiencing some communication issues. Have faced them especially when doing package management.

     

    Also of note (don't think it's anywhere in realease notes) is, that you need to update at least old perl apis or they wont work with 7.5. They will also crash 7.0 hubs.

     

    There were also issues with older .net apis and 7.0, but they've been fixed since. Still, recommended to use the latest api as it's a lot less buggy than some older releases.

     

    -jon



  • 4.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-06-2014 07:50 PM

    Yea I see issues when doing probe management stuff seems to fail quiet often then just try to do it the second time and it works.  I did notice that the hub 7.5 changed the tunnel session pool size back to default supposidly for better performance I usually set them to 20 as this seemed to be optimal in our env specifically when using the tcp_proxy probe.  Which by the way seems like now when that is enabled on all our hubs it starts causing hub disconnects.  I have given up for the most part on support cases for hub disconnects as they say can't replicate the last couple times I opened cases.

     

    Nas 4.3(2)default and updated 4.33 only works with hub 7.5 and it had some bugs related to triggers not processing unless you put a count of greater than 0 in the trigger Nimsoft is aware of this bug as well.  Also the trigger will not read any current alarms you had in your system at the time of the upgrade only new alerts.

     

    I would say maintenance appears to work pretty well the couple times I have used it. 

     

    Also discovery has been modified as within USM now you don't get the state field anymore where you can set devices as managed/ignore/maintenance nimsoft gave us a workaround as we used the state = managed for a bunch of USM filters which where then broke when this happened.

     

    New dashboard designer attempts to import old dashboard buf for the few we had it didn't do very well as all the qos and alert filters had to be redone anyway so I just started from scratch.  The variables in the DD work nicely though.

     

    On a last note our UMP upgrade failed badly and did not work until I blew away all the liferay tables which essentially meant all my custom stuff and any user/groups within liferay were gone and had to be redone.  communties are now sites as well in the new liferay 6.  Good news for anyone using the custom login class that drops users to configured site/community still works with some extra tweaking in the portlet-ext file.



  • 5.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-07-2014 09:51 AM
    Hi,

    we have upgraded to 7.1 from 5.6.1 a month ago. We had connection problems between primary and remote hubs. Go offline occasionally , tunnels stopped working. Afterwards nimsoft support suggested downgrade remote hubs to 5.82. It seems more stable now, however we still occasionally encounter quite number of messages stuck in attach queues problems.

    also currently we encounter robots go offline issues which are on 7.1 ,support suggested to upgrade 7.05(they say its 7.5 version however packaged as 7.05).


  • 6.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-07-2014 04:58 PM

    Updated our Testenvironment from 6.5 to 7.5.

     

    Communication issues on SSL-Tunnels, no chance to go to production with that situation (all Hubs on 7.5, robots on 7.05, as delivered)

     

    Several issues on UMP (export/import on dashboards), also no go for production.



  • 7.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-07-2014 06:02 PM

    Just out of curiosity has anyone else opened cases for hub/tunnel issues.  I think if we have multiple companies open ticket maybe it will get traction instead of can't replicate which I got last time I opened a issue for the tunnels.  That being said increasing the session pool size appears to have helped somewhat from some probe communication issues.



  • 8.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-07-2014 06:04 PM

    Yeah, I know some people who have opened cases about this

     

    -jon



  • 9.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-07-2014 07:21 PM

    I have opened cases , plural, and I have a feeling that they have no clue whats going on. Support will run you through a big ordeal of gathering logs and then it goes no further. Usually if i have something get to the point of escilating , they will put me in touch with dev in ft. collins. With this issue however they have not, that leads me to believe that they are inidated with this issue right now.



  • 10.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-07-2014 10:57 PM

    Ditto here,  It's hard to believe you get a bunch of cases opened for the same issue but yet no issue found.



  • 11.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-08-2014 01:23 PM

    Also think, that support has no Idea what is going on with that SSL-Tunnel, got an answer which told me to insert a heartbeat-Parameter and reduce "Tunnel Hanging Timeout" to 0, well now I do not get any alarms from the tunneldisconnect, well yesterday evening one, but now all queues through the tunnels are disconnecting really  or disconnected :-)

     

    We decided not to update to 7.5, evenso we are unsupported starting 1 July with our NMS 6.5, but that version works at least ^^

     

    cheers

    Matthias



  • 12.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-08-2014 01:34 PM

    I'm disappointed they didn't continue support for 6.5. I know this is how they usually operate, but I also had some talks with them about this before 7.5 was released and they assured they'd make sure 6.5 would still continue to be supported..

     

    I'm really starting to wonder what is the value of being on a supported version though. At least support can't then ask you to upgrade.. if you're on the latest, that is.

     

    I'm still on 6.5 too and not upgrading until a decent release comes out.

     

    -jon



  • 13.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-08-2014 06:56 PM

    I am just looking to build out a new Nimsoft environment to replace an existing (not upgrade) and was going to go 7.5 but looking at the comments here I am now having second thoughts as connectivity issues and queue issues are a big pain.

    Kevin



  • 14.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-08-2014 10:56 PM

    I tried upgrading our test environment from 7.0 to 7.5 and have run into multiple issues and opened multiple cases with Nimsoft.

    One issue I ran into out of the gate with NMS 7.5 was an InstallAnywhere error where it said the install completed with errors and nothing was upgraded.

    Issues I had after upgrade of UMP were the alarm list doesn't render - gives an error that the page is using an unsupported compression.  Another issue is that in USM, Maintenance there is no button to add new schedule and cannot do any of the other Maintenance (ad hoc, drag and drop to schedule, etc)

    Those who have installed - was it a fresh install or upgrade?  If upgrade, did you run into any of these issues?



  • 15.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-08-2014 11:00 PM

    The tunnel issue and disconnects is still an issue?!?  This was supposed to be fixed with the 7.05 controller and 7.5 hub!

    Uggghhh, I regret ever upgrading from 6.5 I swear!  Makes you wonder about the release QA!

    At least version 7.0 was finally pulled off the Downloads.



  • 16.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-09-2014 08:02 AM

    I upgraded from 7.1 to 7.5 without any problems during the installation.

    Also installed 7.5 from scratch on linux & windows without any major problems.

     

    -jon



  • 17.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-09-2014 12:51 PM

    Clean installations has gone without problems, and not big issues found in small sandbox/test environments.

     

    Upgrading from 7.1 to 7.50 went fine and quick. Except for one strange browser thing, but that seems to be IE in TS that is causing issues.

     

    Anyway I have upgraded (why) one larger env hub probes already to 7.50 and there I have quite a lot of issues with tunnels and queues. Sometimes tunnels seem to start flapping on/off quite a lot, normally there are tunneling alarms every some hours but those seem to recover quickly. The issue is if you monitor hub.log, you get a lot of alarms.

     

     



  • 18.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-09-2014 01:58 PM
    So what I am getting from these posts is that 7.0 is a no no, if I am not upgrading but doing a fresh install 7.5 works fine but an upgrade does not, and 6.5 is good to stay on but it will not be supported.....

    Kevin


  • 19.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-09-2014 03:32 PM

    Hi!

     

    We moved our testenvironment back to 6.5 and we will stay with that, I closed all 7.5 related cases, not going to do the Beta-Testing for CA, there is no functional impact for us, the things we do ar working in 6.5 and there is really nothing we need in 7.5.

     

    cheers

    Matthias

     

    P.S. Hoping for 7.51 in some month :->

     

     



  • 20.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-09-2014 04:37 PM

    mgruber wrote:

    ...snip...

    P.S. Hoping for 7.51 in some month :->

      


    Actually, 7.6 is scheduled for end of Q2 I believe. Could be wrong tho.



  • 21.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-12-2014 03:25 PM

    ..... version numbers move way too quickly. I would rather see some stability then focus on how high the version numbers can be driven. I would also like to see UMP dropped for something better.

     

    So far LDAP is broken for me. I was told by tech support it was a limitation. Worked in 6.2, broke after the upgrade.

     

    NAS has issues when selecting the Apply button. Only fix didn't fix it but did make it better.

     

    Report scheduler when running reports is SLOW.. Log shows job errors out but after an hour or so you get the report.

     

    Mobile app misses some alarms.

     

    NAS (Auto Operator) profiles at intervals all defaulted to 1 minute. After a few bug updates they got it fixed for me.

     

    All-in-all I think I opened a dozen tickets on this upgrade and still have 1 or 2 opened.



  • 22.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-12-2014 03:45 PM

    What issues with LDAP you have had?



  • 23.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-12-2014 03:52 PM

    many OU's with many Groups. In IM within ACL where you set the "Set LDAP Group". It errors with (Cannot list LDAP Groups).



  • 24.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-12-2014 04:21 PM

    another thing from the 7.5 upgrade is about half of my systems are now fqdn so within USM I now have shortname and fqdn even though I set all of my robots to name override shortname and QoS shortname. Just something more to deal with.



  • 25.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-12-2014 04:36 PM
    Hi!
    As productmanagement told us, "the market is expecting quiick versionchanges", if I understood it right :-)
    Personally I do not know to whom on the market they are talking to, I personally would expecting a solid running product, and I wouldnt care it the Versionumber is still 6.5 after seven years :->

    cheers
    Matthias

    P.S. I stopped talking about UMP, no words worth in my point of view.


  • 26.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-12-2014 07:31 PM

    market => people who decide what to buy => managers? :smileyhappy:



  • 27.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-12-2014 07:39 PM

    They certainly can't be users.



  • 28.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-13-2014 10:15 AM

    mgruber wrote:
    Hi!
    .... I wouldnt care it the Versionumber is still 6.5 after seven years :->


    +1

     

    Maybe someone should raise an idea to request CA/Nimsoft stop quarterly releases for at least 2 iterations and concentrate on fixing all the bugs/issues and providing some decent documentation (regarding use of callbacks, config section/key information etc). Maybe give their support staff a chance to train on the product/features as well.



  • 29.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-13-2014 02:06 PM

    +1

     

    If the AdminConsole in UMP is suppose to replace IM then BLAH... Heck I can't even find a way to list all of my servers. Each hub only has 50 servers with no next-page. The filter doesn't even see them. That and a lot of the configuration options for the robot is missing. I for one would rather not see it if it is not ready. I do a lot of work in SLM and flash boggs down so much it take 10 times as long to get anything done. If IM goes that way it will really be unusable.



  • 30.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-13-2014 09:20 PM

    Some setting I got from support about tunnel disconnects seem promising haven't got an alert all day and no issues when opening probes.  Not sure if it fixes or just mask the issue but so far so good.  Need to be on the client and server config.

     

    tunnel_hang_timeout = 300

    tunnel_hang_retries = 3

    postroute_passive_timeout = 1000

    postroute_reply_timeout = 120

    postroute_interval = 120 



  • 31.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-14-2014 11:55 AM

    Hi!

     

    Interessting my supporter gave me following as advice, which results in no alarms but disconnecting queues, and after 25h in still disconnecting Tunnels:

    "

    Hello,

    in all hubs, edit the hub.cfg
    find the <tunnel> section
    add the following key:

    heartbeat = 900

    Then, in the <hub> section find the key:

    tunnel_hang_timeout

    and set it to 0, i.e.

    tunnel_hang_timeout = 0

    Please let us know the results.

    Thanks

    "

     

    The result of my message, that replied to that case about the disconnecting Queues and got some sort of in my point Default-Message

    "Hello,

    Please try and set the tunnel_hang_timeout to 300 and let us know the results.

    If the problem persists please take the steps bellow:

    1. upgrade all hubs to Hub 7.50 GA (build 797) first.
    2. if problems persist, set loglevel on hub to 3, and logsize key to 100000
    3. wait for connectivity problems to show themselves
    4. Run the diagnostic script (or batch file) in accordance with the instructions given. It should be run on all hubs at the same time which are involved in the problematic communication path.

    You will have to modify the script to contain the proper Nimsoft admin password, hub info, etc. and then run it (there is documentation included in the zip file.)

    Thanks

    "

     

    After that I closed the call an went back to 6.5 :->

     

    Would be interessing if  Neal's Supporter has a better Idea (will not talk about guess ;->)

     

    cheers

    Matthias

     



  • 32.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-14-2014 05:04 PM

    I really don't know why they have such a hard time resolving this it should be obvious there is a issue with tunneling they guy I talked with was like 7.50 communications are better than all previous releases, yea that may be the case if you don't include 5.8x but whatever.



  • 33.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-14-2014 10:28 PM


  • 34.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-15-2014 02:20 PM

    Noticed that has 820 on the voting scale and still hasn't been flagged as "Under Review" yet the Document System one with only 150 was "Implemented". ?? Go figure....



  • 35.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-21-2014 03:40 PM

    Maybe finally something found with the tunnel code on the hub.  Last update from support.

     

    We believe this behavior may be the result of a defect with the tunnel code and the hub developer is investigating a fix



  • 36.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 05-21-2014 04:04 PM

    Worth mentioning is that the hub package that comes with the NMS 7.5
    installer has an older build version of windows hub binary.

     

    Need to download the lastest hub package from archive to get one that
    also contains the 797 build of the hub probe for windows.



  • 37.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-17-2014 06:40 PM

    I have to build out a new Nimsoft environment (currently running 6.5) and I saw 7.5 was available and also saw this thread. I was just wondering if anything has changed much on 7.5 since the last post 4 weeks ago? If not I think I am going to have to build my new environment on 6.5

     



  • 38.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-18-2014 10:38 AM

    My 7.5 environment is fairly stable as long as I use robot v7.05 and
    not the 7.10 robot. I still have a small problem when a robot is
    uncreachable and it causes the hub to flap in IM.

     

    Not sure if that is just a visual problem in IM or an actual hub
    problem.

     

    Supposedly, the hub v7.50 also has a problem with chained tunnels.

     

    Also not sure if the problems with the nas has been resolved. I haven't
    observed that problem myself, so couldn't tell.



  • 39.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-18-2014 10:49 AM

    We have now at least four customer environments running 7.50, no big problems. We have done those tunneling tuning told in articles.

     

    Last night again one bigger env upgraded, tens of tunnels there. No big issues yet.

     

    (hey, we must also tell some positive things here!)



  • 40.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-18-2014 05:21 PM

    7.6 is due out by end of month which is supposed to fix alot of the 7.5 bugs/issues specifically the hub problem which has existed since version 6.



  • 41.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-18-2014 06:18 PM

    Thanks guys, happy with all positive or negative comments, just hoping to make a balanced judgement on what to install.

     

    I appreciate the feedback

     

    Kevin



  • 42.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-20-2014 12:28 PM

    I had confirmation from CA Support that 6.5 is EOL for support July this year so it kind of answers my question as to what version I am going to build out so will probably wait for the next release at the end of this month mentioned in an earlier post.

     

    One thing I would like to confirm is thta the compatibility matrix for 7.5 says MS SQL 2008 R2 or 2012, but it does not say if it has to be Enterprise or can be Standard, any ideas please?

    Thank you

     

    Kevin



  • 43.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-20-2014 02:17 PM

    ntimm wrote:

    7.6 is due out by end of month which is supposed to fix alot of the 7.5 bugs/issues specifically the hub problem which has existed since version 6.


    I noticed that the 7.5 on the downloads section is a newer build (430) that the one first released April so that may contains some of the 7.6 fixes maybe ?!? (but without a comprehensive change history we'll never know for sure).



  • 44.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-25-2014 04:39 PM

    It seems 7.6 GA (build 567) is now available so I am looking to make use of this version to build out a new environment, new primary hub, UMP, SQL and tunnel servers. One question I have is that I want to attach existing hub servers to the new environment and they are currently running version 5.82, so I was wondering if I upgrade these first before I connect them to the new 6.6 environment or I attach them and then upgrade them?

     

    Any thoughts on the best way to apporoach this would be appreciated

     

    Not sure if this would be better posted to a 7.6 specific thread or not.......

     

    Thank you



  • 45.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-25-2014 05:39 PM

    Hi,

     

    Both will work, but if you're going to upgrade, I'd go all the way and update them at the same time. Usually I first upgrade hubs, then NMS.

     

    -jon



  • 46.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-26-2014 08:36 AM

    After upgrading to 7.6 when it came out, I've gotten hundreds of alarms like this:

     

    The queue file '178.sds' for 'nas' experienced an error (43 msgs affected)

     

    they're level warning.. will have to look more closely at them. They come from all queues.

     

    -jon



  • 47.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-27-2014 10:33 AM

    sounds unlucky....

     

    Well I am in vacation starting 7th July, going to check NMS 7.6  and my Upgrade from 6.5 to it, when I am back in erlay August, hopefully some patches arrives till then ;-)

     

    cheers

    Matthias

     



  • 48.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-27-2014 12:43 PM

    Yeah, wasn't nothing reboots didn't fix.



  • 49.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-27-2014 04:02 PM

    I have been working with Nimsoft support and development  for the last month and half since our NOD environment was upgraded to 7.5. We have had numerous issues, mostly around tunnel stability and routing of our secondary and tertiary hubs (hub.sds file sync). The routing is the foundation for all probe communication to function properly; especially when it comes down the discovery, inventory, probe deployment, and security.

     

    Last week we implemented the 7.6 hub rc build 2145-dev . The tunnel stability was improved but the routing issues remain. Today I will testing out hub 7.6 rc build 2173-dev, which contains the following fixes:

     

    * checks the routing tables (hubs.sds as well as the internal memory)

    *determines whether a "local" route has been inserted for a tunnel client

        ** if so, it automatically corrects this with the correct IP and port for a tunnel connection.
    *each tunnel control thread will check the routing cache every 3 seconds for a route to its own tunnel

       **if all is good, you'll see this type of message in the logs at log level 3 or higher:
           Jun 26 15:54:05:108 [140459070428928] hub: CTRL gmc-Suse13-2 routing ok (10.238.20.142:35234)

        **if a change has occurred, and it needs repaired you'll see this at log level 1 or higher:

            Jun 26 15:54:05:702 [140459070428928] hub: CTRL gmc-Suse13-2 routing repaired (10.238.20.142:35234)

    *for best results place this on any hub that's connected by a tunnel

    *non-tunnel hubs can continue to use the previous build.

     

    I will keep ya'll posted. Fingers crossed!



  • 50.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 06-30-2014 11:43 AM

    Thanks for the information, quite interessting, looking forward for news

     

    Cheers

    Matthias

     

     



  • 51.  Re: Status on Nimsoft Monitor 7.5 release

    Posted 07-02-2014 12:07 AM

    Thank you for that info, glad I read this thread before testing the new HUB, this is great info to know