Clarity PPM

Expand all | Collapse all

String filters in Portet

Jump to Best Answer
  • 1.  String filters in Portet

    Posted 08-03-2009 04:53 AM
    Hi  All,           We have implemented filters in query using parameters which are of the data-type String. When we configure these filters in the portlet, we get default display as 'Exact Text' and in the portlet ' = Exact' is displayed at the bottom in the portlet. Is there any way, where we can remove these ' = Exact' part from the portlet display.    Regards,Jaspreet


  • 2.  Re: String filters in Portet

    Posted 08-03-2009 05:16 AM
     What "type" of portlets are you talking about (NSQL / Object based?)  --  You can certainly "wild card" text searches in "normal" NSQL-based portlets...  I'm guessing your parameters are the @PARAM@ type things, in which case you'll have to "code" in the "LIKE" logic into your NSQL to get that to work.      


  • 3.  Re: String filters in Portet

    Posted 08-03-2009 05:45 AM
    Hi Dave,  We are using Grid Portlets. Database object is NSQL query.Using the query, we were able to achieve the wild card search.But the problem is, we are not able to remove the clarity out of box legend which says, '  = Exact'.Since the search is not an exact search but a wild card search, we want to remove this ' =Exact' legend at the bottom of the portlet.The display of this legend gives a wrong picture to the user.Any help/workaround on this will be greatly appreciated.  Thanks & RegardsJaspreet


  • 4.  Re: String filters in Portet

    Posted 08-03-2009 07:32 AM
    OK I misunderstood - you only want to get rid of that ugly text displayed by the application...  Hmmmm, don't think I know a good answer to that.... that text is not controlled by the language options (NLS) and I can't find it the application code I can see either - sorry!     Message Edited by Dave on 08-03-2009 04:32 PM [left]


  • 5.  Re: String filters in Portet

    Posted 08-03-2009 07:48 AM
    Hi Jaspreet,Under Portlet->List Filter section->Fields->Click on properties  icon  of parameter ->Change display type from Exact Text to Text Entry.. If @param@(in your query) is used in your porltet  filter then I don't think so you can change display type.  '  = Exact'   is driven by attribute display type.  ThanksSiva Message Edited by sivasairam on 08-03-2009 11:52 AM [left]


  • 6.  Re: String filters in Portet

    Posted 08-03-2009 08:00 AM
    ^ I think you can only do that on filter fields that are "returned data" (i.e. change from/to "Text Entry" / "Exact Match").  Certainly I can not do that on a filter field which has been created from an @WHERE:PARAM:USER_DEF:STRING:myfield@ construct in the NSQL.  (unless you know different? - I'm in version 8.1)    


  • 7.  Re: String filters in Portet

    Posted 08-03-2009 08:04 AM
    You are right Dave..That's what I meant in my post.  I should have put my words in a different way.


  • 8.  Re: String filters in Portet
    Best Answer

    Posted 08-03-2009 08:51 AM
    Hi,Add the parameter in your query select list and then show that  in your project  filter..  Iam not sure whether this  works..but just an idea that struck my mind  select @SELECT.......:first_name:ff@,                   @SELECT.......:projname:projname@....  from(select a.first_name,                                   @where:param:user_def:string:projectname@ projnamefrom...where...)--------      -Siva      


  • 9.  RE: Re: String filters in Portet

    Posted 08-28-2012 10:37 AM
    (bump)

    ...and it still seems to work this way in V13.

    (i.e. that if you define in your NSQL a user-supplied parameter that is a text entry field like @WHERE:PARAM:USER_DEF:STRING:my_parameter@, then if we don't associate that with a lookup then we get forced to have that param_my_parameter filter field as "Exact Text" in the portlet filter-field properties and we get the nasty purple GUI hint on screen. We could of course have "coded" our NSQL query such that the parameter is NOT used in an "Exact text" manner (e.g. we could code it using a LIKE condition) and so we don't want the GUI hint displayed. Boo. )


  • 10.  Re: String filters in Portet

    Posted 04-04-2017 06:09 AM

    Hi,

    I am also facing same issue in 15.2 version. I have created a hierarchical portlet having two levels:level1 is project and level 2 task , I created a task filter as text field and in the query I have use @param@:user_def_.... like '%%' but still at UI im getting excat " =" symbol in front of the filter.  I want "="  excat symbol to be removed since its confusing for the users. Any help is highly appreciated. Thanks

     

    Regards

    Ritesh



  • 11.  Re: String filters in Portet

    Posted 10-04-2018 02:55 PM

    HI, could you provide the exact syntax you have used to get the filter to work on wildcards?  I have been trying to get mine to work and have not been able to find examples that just spell it out.  Thanks