The Water Cooler

Expand all | Collapse all

AEAT-9000-1GSH0 with EPOS4 issue

  • 1.  AEAT-9000-1GSH0 with EPOS4 issue

    Posted 04-04-2019 12:01 AM

    Hey everyone,
    I am an engineer for our company's robotics team and we are facing some technical difficulties, so I would like to ask for some help.


    We would like to use the AEAT-9000-1GSH0 encoder that we purchased with a Maxon EPOS4 50/5 controller, with SSI protocol. We have managed to connect the devices together, however after configuration, the encoder value keeps floating instead of giving one, steady value.

    Our current wiring and settings are as stated below, please review it for me, and kindly suggest me a different wiring and settings if necessary.
    If with the below settings and wiring the product should work, is it safe to assume that it is a faulty model?


    pin             EPOS4 pins   AEAT-9000 pins
    CLK            5                  28
    /CLK           6                  30
    DATA(SSI)   7                  22
    /DATA(SSI)  8                  20
    GND           9                  6,8,17,18,14
    +5 VDC      10                27,29,16

    Required settings on EPOS4, and our current settings:

    - SSI data rate : 1500 kbit/s (min. 400, max 2000)
    - SSI number of data bits : single turn: 17 (min. 6 max. 23) (multi-turn and special bits set to 0)
    - SSI encoding type : Direction: maxon, Encoding type: Gray coded data
    - SSI timeout time : 50 μs (20 μs required according to AEAT-9000 datasheet)
    - SSI refresh frequency (automatically set by EPOS STUDIO, vary between 25'000, 12'5000, 5'000 Hz)
    - SSI power up time : 10 ms (500ns required according to AEAT-9000 datasheet)

    After further experimenting with the AEAT-9000-1GSH0 encoder, we experienced the following:
    We supplied the required 5V through a signal generator to the encoder, and tried to see any form of signal coming from the encoder with an oscilloscope. Also, we measured the on-board voltages.

    On the VDD pins, after connecting +5V from the power source, we experienced a voltage draw, meaning that even when feeding the power straight from power source through a short cable, the voltage measured on the respective I/O pin of the encoder board was only 3.6V-4V, only sometimes peaking u to 5V. In other words, it was inconsistent.

    After failing to get any results from the 2 wire SSI protocol pins, we simply tried to use the unit in Incremental mode, with Incremental A and Incremental B pins, without a success. After connecting the encoder to the power source, on Pin A we experienced a constant high value, while on Pin B a constant low value, with an additional, sinusoidal noise wave form with an amplitude of a few hundred mV-s. The values never changed, doesn't matter how we turned the position plate, we did not manage to get any increment or decrement ticks on the respective pins.


    Is it safe to assume that the unit is broken?


    For further information refer to the following section of the datasheets:
    - EPOS4 50/5 Hardware Reference, 3.3.6 Sensor (X6)
    - EPOS4 Firmware Specifications, 6.2.55 SSI absolute encoder
    - AEAT-9000-1GSH0 (Full Option) Data Sheet, page 7.


    Also, I am attaching a few pictures that might help.

    Best regards,
    Zsolt Bagoczki


  • 2.  Re: AEAT-9000-1GSH0 with EPOS4 issue

    Posted 04-04-2019 12:14 AM



    I think you are here in a totally wrong forum.


    the product you refer "AFAIK" is not a Retail Product, for that reason for Support you have to contact the OEM in such case Maxon.  


  • 3.  Re: AEAT-9000-1GSH0 with EPOS4 issue

    Posted 04-04-2019 12:26 AM

    The question is the usage or faultiness of the AEAT-9000-1GSH0 absolute encoder, which is a Broadcom product, not a Maxon product.
    The Maxon controller works perfectly.


  • 4.  Re: AEAT-9000-1GSH0 with EPOS4 issue

    Posted 04-04-2019 12:56 AM



    nobody have a doubt this is not a Broadcom Products, however is not supported directely by Broadcom or trough this Community.


    For Support whatever its is, malfunction or defective, you have to contact the Vendor/ OEM / or Reseller.